x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Package Shipping problem, no Steam

Hi, I have scoured all other topics on this but no solution so far

I have created a blank project and installed advanced steam sessions which happily connects to steam using the test 480 id when in standalone and development packaging. The popup below appears and I am able to open the overlay that shows the test Spacewar and that the achievements are working

alt text alt text

The project simply grabs the player name from the player state class and displays it on screen

But.... when I package as "Shipping" there is no STEAM popup (as above) and Shift-Tab does not bring up the steam overlay. If I launch through steam (launch non steam game) still no popup. It is as if steam has been disabled, the steam name is not retrieved and the DESKTOP-(identifier) is displayed instead.

  • I am running 4.19.2 with 1.39 steam SDK (the same as in the engine folder).

  • All plugins are enabled, Advanced Sessions / Advanced steam sessions / online subsystem steam.

  • I have steam_appid.txt with 480 no white characters inside next to my 64bit binary.

  • The steam dll is in its \Binaries\ThirdParty\Steamworks\Steamv139\Win64\steam_api64.dll.

  • I have verified the engine which has not been modified.

  • There is no C++ in the projects.

  • The defaultengine.ini has all the needed code and the 480 id as per the other 100 threads.

I am at a loss to why this isnt working

Any help would be great

Thanks.

Product Version: UE 4.19
Tags:
1.jpg (39.2 kB)
2.jpg (135.4 kB)
more ▼

asked Sep 26 '18 at 04:01 PM in Packaging & Deployment

avatar image

KelDG
27 6 8 15

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question