x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Having trouble applying local force using world coordinates (pics included)

I have a pawn that's aiming to have 6DOF with physics based movement. I've implemented vertical, strafe, and forward motion and all their forces are correctly aligned with local coordinates like so:

alt text

It's lack of wobbling also confirms that the pawn's origin and center of gravity are aligned.

For yaw, pitch, and roll, I want to apply a force a consistent distance (in this case, 100m either forward or above the model) to make it turn.

alt text

As a starter I have a constant force being applied towards the right, 100m fore of the model, which should make it yaw right. However best case it ends up wobbling off-axis uncontrollably. Worst case it radically changes direction every few seconds. I changed the 100m vector to 0 so that it should act the same as Add Force for strafing, but it still wobbles in an inconsistent manner. The wobbles are the same as what my vertical, strafe, and forward blueprints did before I got them using the right transforms.

I've tried Add Force at Location, Add Force at Location (Local), Add Torque, and every combination of Inverse Transform, Transform, Invert Transform, Get Relative Transform, Get Actor Forward/Right/Up Vector with no solution. Tried the following example blueprints:

https://answers.unrealengine.com/questions/495309/applying-torque-in-local-space-on-a-physics-driven.html https://answers.unrealengine.com/questions/25535/add-torque-in-local-space.html

and several others. I removed the strafe, vertical, fore Force section of the blueprint in case anything there was throwing it off but still no dice.

Product Version: UE 4.20
Tags:
s1.jpg (113.9 kB)
s2.jpg (140.3 kB)
more ▼

asked Sep 26 '18 at 11:07 PM in Blueprint Scripting

avatar image

temp89
6 2 3

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Solved it myself. Turns out the issue was that UE4 think the CoM is different from what 3dsmax does. Add Force automatically aligns itself with the CoM rather than the mesh origin. Once I accounted for it it was fixed.

more ▼

answered Sep 28 '18 at 08:03 PM

avatar image

temp89
6 2 3

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question