x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Ubuntu UE4Editor build failure, what may be the issue?

I'm trying to build UE4 from source, the release version on:

  • Ubuntu 18.04 LTR (lxde (lubuntu))

  • gcc-6 and gcc-7 (same error on both tries)

  • AMD A6-6400K APU

  • GeForce GTX 1080

  • 8 GB ram

  • cuda 9.1

The build took a lot of time (hours) until failing. I've tried it the last few days about 4 or 5 times already, both on ubuntu 16.04 LTR and on 18.04. About two years ago, it built successfully and ran flawless from first try, but i had a different hardware setup.

the error is:

... ERROR: UBT ERROR: Failed to produce item: /home/feral/unrealEngine4/UnrealEngine/Engine/Binaries/Linux/libUE4Editor-MovieSceneCaptureDialog.so (see ../Programs/UnrealBuildTool/Log.txt for full exception trace) Total build time: 12834.43 seconds (Local executor: 0.00 seconds) Makefile:188: recipe for target 'UE4Editor' failed make: *** [UE4Editor] Error 5

the log is:

... ActionThread.ThreadFunc: [1579/1592] Link (ld) libUE4Editor-BlankPlugin.so ActionThread.ThreadFunc: [1580/1592] Link (ld) libUE4Editor-PythonScriptPluginPreload.so ActionThread.ThreadFunc: [1581/1592] Link (ld) libUE4Editor-UE4Game.so ActionThread.ThreadFunc: [1582/1592] Link (ld) libUE4Editor-XGEController.so ActionThread.ThreadFunc: [1583/1592] Link (ld) libUE4Editor-IPC.so ActionThread.ThreadFunc: [1584/1592] Link (ld) libUE4Editor-Advertising.so ExceptionUtils.m_1: ============================================================================== ExceptionUtils.m0: ERROR: UBT ERROR: Failed to produce item: /home/feral/unrealEngine4/UnrealEngine/Engine/Binaries/Linux/libUE4Editor-MovieSceneCaptureDialog.so ExceptionUtils.m0: (see ../Programs/UnrealBuildTool/Log.txt for full exception trace) ExceptionUtils.m1: ExceptionUtils.m1: BuildException: UBT ERROR: Failed to produce item: /home/feral/unrealEngine4/UnrealEngine/Engine/Binaries/Linux/libUE4Editor-MovieSceneCaptureDialog.so ExceptionUtils.m1: at UnrealBuildTool.ActionGraph.ExecuteActions (UnrealBuildTool.BuildConfiguration BuildConfiguration, System.Collections.Generic.List`1 ActionsToExecute, Boolean bIsRemoteCompile, System.String& ExecutorName, System.String TargetInfoForTelemetry, EHotReload HotReload) [0x00000] in :0 ExceptionUtils.m1: at UnrealBuildTool.UnrealBuildTool.RunUBT (UnrealBuildTool.BuildConfiguration BuildConfiguration, System.String[] Arguments, Tools.DotNETCommon.FileReference ProjectFile, Boolean bCatchExceptions) [0x00000] in :0 ExceptionUtils.m_1: ============================================================================== UnrealBuildTool.RunUBT: Total build time: 12834.43 seconds (Local executor: 0.00 seconds) (END)

What may be the issue? thanks

^ _ ^

Product Version: UE Github Master branch
Tags:
more ▼

asked Sep 29 '18 at 02:51 PM in Linux

avatar image

delta_delta_x
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey, couple questions.

Why the master branch and not Release or 4.20? - Master might have issues that are yet to be resolved, also it is not recommended to be developing anything on it as things are prone to break and change there.

Did you do all the required steps? https://wiki.unrealengine.com/Building_On_Linux#Building

I am not sure about gcc support, current versions of the engine do carry the entire toolchain with it so that should not even matter.

more ▼

answered Sep 30 '18 at 02:48 PM

avatar image

Acheta Games
859 10 13 20

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question