x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Viewport and component tab missing from blueprint.

Before I start writing this, I should probably mention that I have looked at other issues with similar descriptions, but none of the answers worked.

Now, I was following the First Person Shooter Tutorial in the UE Docs and had reached 2.7. By this point, I had already interacted with the viewport tab and changed skeletal and location for the character blueprint. This is when I decided to close for the day and do something else. Then, this morning, I opened up my project to continue and noticed that the blueprint component and viewport tabs were missing. They could not be opened from the Window button either.

Bottom line: They were there before and I used them. Now they're not and I can't get them back. What in the world do I do?


(I have tried the Reset Layout button.)

(This also applies to the other blueprint made in the tutorial.)

Product Version: UE 4.20
Tags:
more ▼

asked Sep 30 '18 at 10:46 AM in Using UE4

avatar image

MadKreativity
8 2 4

avatar image Shadow Boss12 Sep 30 '18 at 01:33 PM

Hello. Did u tick them in the windows drop down ?

avatar image MadKreativity Sep 30 '18 at 01:44 PM

They don't appear in the window tab dropdown.

avatar image Shadow Boss12 Sep 30 '18 at 01:51 PM

alt text

avatar image MadKreativity Sep 30 '18 at 02:39 PM

Yes, I know where they're supposed to be, but they're not there. There's Toolbar, Class Defaults, Find Results and My Blueprint. And at the top it says Defaults Editor.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Do you have this prompt perhaps? alt text

more ▼

answered May 01 '19 at 11:48 PM

avatar image

Chkoupinator
132 1 5 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

hi, i resolved the issue by clicking edit in the context menu of a blueprint (in the content browser) and then it suggested to me to open blueprint if a full editor, click there and it will open blueprint editor with standard layout (all the tabs: Viewport, Construction script, Event graph, details, components, my blueprint)

more ▼

answered Mar 03 '19 at 08:35 AM

avatar image

demoth
1 1

avatar image U24 Solutions Apr 29 '19 at 08:30 AM

Pressing Edit didn't prompt me to use full editor. So bump for help!

avatar image Chkoupinator May 01 '19 at 11:45 PM

I have the same issue as well, even by going to window I can't even find the Viewport Screenshot of Window menu

Edit: not even a minute after that I found a note on top of the main opened tab (which was the details tab I assume) prompting me to open the full editor

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question