x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Warning: The imported mesh is very small. This is most likely an issue with the units used when exporting to FBX.

Warning: The imported mesh is very small. This is most likely an issue with the units used when exporting to FBX. how can i fix this

Product Version: UE 4.19
Tags:
more ▼

asked Oct 01 '18 at 06:05 PM in Using UE4

avatar image

Anmar Sadiq
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It is only a warning. If the mesh is importing too small for what you want, you have a few options:

  1. Make it bigger in the program that you export the mesh from.

  2. Use different units of measurement in that same program so they more closely match Unreal's (1 Unreal Unit = 1 centimeter).

  3. When you import the mesh, the FBX import dialog has an option for scaling the import. Put a larger number in that field before completing the import.

  4. (not recommended) Just scale the mesh in Unreal wherever you need it bigger. This option is not recommended because you will have to do it in EVERY case where you want the mesh bigger. If it is imported already big you don't have to bother yourself with it all the time. Also, lots of scaling can throw off other things you want to do within the game and introduce rounding errors if it's extreme.

more ▼

answered Oct 01 '18 at 06:31 PM

avatar image

mightyenigma
3.8k 18 20 20

avatar image duderseb Oct 01 '18 at 07:02 PM

To add to mightyenigma's:

  1. Make sure your DCC's default unit is set to centimeters (1uu in UE4 = 1cm).

  2. Reset your mesh transforms before exporting.

  3. Check you're using the correct FBX version for the content you're authoring.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question