x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Anim Notifies not firing in packaged game.

When using Dynamic Combat System, any custom Anim Notifies , except one (ANS_ToggleImmortality), do not fire when tested in either a development or shipping build. The Anim Notifies work just fine in PIE, and in PIE Standalone.

https://www.unrealengine.com/marketplace/dynamic-combat-system

I have tried testing by doing the following:

On a new ThirdPerson template project, without anything added, custom Anim Notifies fire in a packaged game.

Once I added the Dynamic Combat System by migrating it into the ThirdPerson template project, the custom Anim Notifies that I previously made and confirmed were working no longer fire in a packaged game.

Creating and packaging a game from just the Dynamic Combat System also do not fire Anim Notifies.

In the ThirdPerson template project, I removed the Dynamic Combat system, and the custom Anim Notifies work in a packaged game again.

The only working Anim Notify that does fire in a packaged game from the Dynamic Combat System is ANS_ToggleImmortality. All parts of this custom Anim Notify (begin, tick and end), all work. I have tried duplicating the Anim Notify State and also making another Anim Notify State BP using it as a parent both do not work in a packaged game.

I have tried these tests on 4.19.2 and 4.20.3

UPDATE: Tested on 4.18 : works as intended.

On 4.19, with advice from the asset pack author, I moved all Blueprint classes to the content folder and it works as intended.

Product Version: UE 4.19
Tags:
more ▼

asked Oct 07 '18 at 05:18 AM in Packaging & Deployment

avatar image

bruize10
31 3 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question