x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't Generate Project Files - Unauthorized access to other PC's accounts

I have been working with UE4 and C++ for soon 2 years so I'm not new to this.

Today I tried generating project files again, but the following error message appeared:

alt text alt text

In the 2nd screen you can see that the system is looking for some log file in my primary account, which I'm always using (full name as user). In the 2nd line of the first screen, you can see that it wants to access the user with only my first name, which is a 2nd user I once created on my PC for some reason, which I literally never used. I have also now deleted this user, but it's the same error message coming up and I haven't changed anything really.

I already tried re-installing the engine, which didn't help. I also tried out unchecking the read-only status for UE4, as that was the only clue I found regarding unauthorized access disabling solution generation. Nothing happened. This is seriously hindering my ability to work and I have no clue whatsoever what is causing this or how I can change this.

EDIT: Going by another user's question, it seems to be a white space issue and I just coincidentally had a 2nd user with the same name as the "cut" part of the actual path. This needs fixing ASAP.

Product Version: UE 4.20
Tags:
more ▼

asked Oct 08 '18 at 08:35 PM in Installation & Setup

avatar image

Herr Edgy
89 8 12 17

avatar image DaKenpachi Oct 15 '18 at 03:45 PM

Have you tried disabling your firewall? I had an issue with my companies´ kaspersky simply blocking some paths, which wouldn´t let me generate sln files either

avatar image Herr Edgy Oct 15 '18 at 04:30 PM

Apparently this was just a huge coincidence; the error is in UBT not understanding white spaces in paths for some reason anymore.

I managed to circumvent this problem by running UBT on the command line and specifiying the path myself, because there it actually works with white spaces.

avatar image SirTainly Oct 23 '18 at 08:56 PM

Out of nowhere after updating to UE 4.20.3 i got this pesky crap too and i have since tried to come up with a remedy but have failed the quest.. for 3 days and with re-installing most of the VS modules, reparing VS install, removing UE 4.18, 4.19 and 4.20 installs, cleaning registry, rebooting e.t.c e.t.c e.t.c.. Seriously starts to itch to blow something up.

Also got around it by using commandline and manually build the projectfiles.. but maaaan..tedious as f*ck if you ask me..

Is this an acknowledged / reported bug? Is there a way to fix this and not having to remove a cluster humongous VS install alltogether? ..id rather cut two not-so-useful fingers off before resorting to this

avatar image Herr Edgy Oct 23 '18 at 08:59 PM

Hey, I'm sorry to hear that you had those problems as well! I probably should have written the answer here as well; I did so in another thread with the same problems. I will do so now. I wrote a batch script that lets you build any project via command line rather easily

There was staff answering there, but I'm not sure if they actually acknowledged the bug and registered it as something to be fixed.

avatar image SirTainly Oct 24 '18 at 08:35 AM

Thanks man. Yes i found that answer in the other thread ( also read all other threads related) and also acknowledged the probable whitespace issue, and that was the part i tried to circumvent :)...

The batchfile is a tremendous help in this situation and will help a lot of people, so hat's off for the effort, thanks.

I googled the issue franticly yesterday when trying to find a fix and there's more than a few posts that might be related to it, even posts on other sites ( believe it or not) so it might be well worth the effort to make a report.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I found out that the actual problem was not because of another account, that was just a coincidence. The actual problem is a whitespace problem, cutting the path of the project off when encountering a white space.

I wrote a batch script that anyone can use to build any project. Paths inside of the batch script might need to be changed though.

  REM Project must be in FirstName LastName\Documents\Unreal Projects to work
  
  @echo off
  set /p projectName="Enter Project to generate files: " 
  "C:\Program Files\Epic Games\UE_4.20\Engine\Binaries\DotNET/UnrealBuildTool.exe" -projectfiles -project="C:\Users\FirstName LastName\Documents\Unreal Projects\%projectName%\%projectName%.uproject"
  
  @pause

The first path should be self-explanatory. The second path has to point to the folder where your unreal projects are situated in, with the added \%projectName%\%projectName%.uproject", so at the very least you need to replace the "FirstName LastName" part with your actual name. This batch script will ask you to type in the name of your project, for example "BestProject" (without the quotation marks).

more ▼

answered Oct 23 '18 at 09:04 PM

avatar image

Herr Edgy
89 8 12 17

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello, I know I might be late for the party, but I've been experiencing such issue in 4.20.3 and had it solved by normally opening the editor project and subsequently selecting, from the very editor (NOT by right clicking the .uproject file) File->Generate Visual Studio Solution. I hope this can be of any help.

Cheers!

more ▼

answered Nov 11 '18 at 06:44 PM

avatar image

NyanFasian
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question