x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Abnormal AI Behavior with Nativization on Blueprints

Hello all,

I am having some trouble making AI follow a spline path or move to target destination using nativized blueprints. I am using Inclusive nativization, and most all other aspects work perfectly fine it just seems to be the move to location.

AI Pawnsense & EQS Reset (The only real blueprint here, there is a cast to base class AIController above and saved to var AIC) alt text

AI Controller alt text

Behavior Tree alt text

Layout in Editor alt text

Just to be clear the only problem seems to be the splines, all other behaviors work as intended. Splines also work fine in editor but break upon nativization. Sorry if the code is a little messy, I have been desperately trying different methods to see if any would fix the problem.

Things I have tried: -Service to update Blackboard Vars with spline locations -Task to update Blackboard Vars with spline locations -Using on Possessed in Pawn Blueprint -Using on Possess in AIC -Detaching a scene component instead of spline for target location

All yield the same result. Some breaking the code even further disallowing the entire tree to run.

Thanks for any and all help!

Product Version: UE 4.20
Tags:
pawn.png (161.2 kB)
aic.png (98.7 kB)
behavior-tree.png (219.8 kB)
splines.png (1.4 MB)
more ▼

asked Oct 10 '18 at 03:31 AM in Packaging & Deployment

avatar image

tehdoxxer
6 1 4

avatar image tehdoxxer Oct 10 '18 at 03:57 AM

Just created a task to output the location of both Vectors, seems the coordinates on the failing pawns have intense shifting. With the coordinates about 140k units away.

Putting a delay on the variable assignment, but not sure how much good it will do me.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I got it working but had to remove the spline functionality. Seems there were some problems initializing, the solution for me was to use a target actor a service that checks the distance to target actors.

Here is the code if it helps anyone else: alt text

The Service: alt text alt text

servicept1.png (228.6 kB)
servicept2.png (336.6 kB)
more ▼

answered Oct 10 '18 at 10:40 PM

avatar image

tehdoxxer
6 1 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question