x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android packaging Error: resource android:attr/fontStyle not found.

Packaging for android gives me this error:

PackagingResults: Error: resource android:attr/fontStyle not found. PackagingResults: Error: resource android:attr/font not found. PackagingResults: Error: resource android:attr/fontWeight not found. PackagingResults: Error: resource android:attr/fontStyle not found. PackagingResults: Error: resource android:attr/font not found. PackagingResults: Error: resource android:attr/fontWeight not found. PackagingResults: Error: failed linking references.

Any ideas what font and where I should check for this? My game isn't using any font at all.

Product Version: UE 4.21 Preview
Tags:
more ▼

asked Oct 12 '18 at 02:03 AM in Packaging & Deployment

avatar image

Feureau
161 16 25 39

avatar image HVS_RHS Oct 13 '18 at 08:07 AM

Hi der

I've had same problem. Try to download any font u like and set that new font in all ur widget or text. Delete ur intermediate and saved game folder from project directory and try to recompile.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Turns out this has got nothing to do with font.

Go to Project Settings > Platform > Android SDK

Set SDK API Level to latest, and set NDK API Level to latest.

more ▼

answered Oct 19 '18 at 06:53 AM

avatar image

Feureau
161 16 25 39

avatar image llll Sabre llll Nov 16 '18 at 11:17 AM

This didn't work for me. I tried this yesterday.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Don't forget to update your codeworksforandroid to 1R7u1

in \Program Files\Epic Games\UE_4.21\Engine\Extras\AndroidWorks

more ▼

answered Nov 16 '18 at 02:01 AM

avatar image

JobvW
43 9 13 15

avatar image llll Sabre llll Nov 16 '18 at 11:18 AM

I am considering trying this, but I am quite worried about my main project which is 99% complete and is running and packaging fine to Android in 4.19.2 (Which I think is using 1R6U1) Should I be right to be concerned? Will installing 1R7u1 (for 4.21) possibly screw that up? (I have deleted my Answerhub issue as it is pretty much a duplicate).

Thanks!

avatar image JobvW Nov 16 '18 at 12:10 PM

I would recommend installing the new version, if your older project is not running you always install the older codeworks (if it automatically removes the old one). Also don't forget to update your sdk config in your project settings.

avatar image llll Sabre llll Nov 16 '18 at 04:27 PM

Thanks jobvw! After installing 1R7u1 (and updating the SDK config to match any changes), the blank project packaged first time in 4.21. I then went back to my project in 4.19.2 and thankfully it packages still without a hitch! PHEW!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question