x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Visual Studio not found

I recently installed UE4 after installing visual studio 2017. I installed pretty much every single box on the visual studio installation but for some reason whenever I open UE4 and try switching to C++ it says that I need to install visual studio to use it. Already tried uninstalling UE4 and installing again and restarting my computer, can't find solutions anywhere on the internet.

Product Version: UE 4.20
Tags:
more ▼

asked Oct 14 '18 at 11:50 AM in Installation & Setup

avatar image

BolinhoDeArrozB1
1 1 2

avatar image cyadic Apr 02 '19 at 01:41 PM

hey guys did any of you manage to find a solution about this issue ?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

5 answers: sort voted first
more ▼

answered Oct 14 '18 at 03:53 PM

avatar image

GIGA-Money
237 2 11 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Yes, I did install C++ in visual studio installer including the UE4 installer and lots of additional boxes. I just tried installing the UnrealVS extension and it appears on VS but whenever I open UE4 and select C++ tab it still says that that no compiler was found alt text

ue4-error.png (6.1 kB)
more ▼

answered Oct 14 '18 at 05:11 PM

avatar image

BolinhoDeArrozB1
1 1 2

avatar image TheDreamCatcher Oct 14 '18 at 06:51 PM

int Engine/Config check in Window/WindowsEngine.ini check if you have a category [/Script/SourceCodeAccess.SourceCodeAccessSettings] if so just delete this line and the PreferredAccessor= line. You can also check the BaseEngine.ini in the Config folder.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Can't find any of those lines in both files

more ▼

answered Oct 15 '18 at 07:23 AM

avatar image

BolinhoDeArrozB1
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Have you tried starting a BP project, and change the preferred source code settings there. Editor Preferences -> General -> Source Code -> Source Code Editor then you could see if that project will power up VS.

more ▼

answered Oct 15 '18 at 03:44 PM

avatar image

GIGA-Money
237 2 11 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Just did it, changed the preferred source code to Visual Studio 2017 but still when I try to create a new C++ class it says that no compiler was found (check the screenshot above for reference)

more ▼

answered Oct 15 '18 at 03:59 PM

avatar image

BolinhoDeArrozB1
1 1 2

avatar image GIGA-Money Oct 15 '18 at 09:16 PM

Real anomaly.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question