x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

[Closed] Debug Game in "MyGameEditor (Debug)" Run Config

Hi Guys, can anyone tell me why I can not run the auto generated configuration to debug my game. It keeps telling me that

 LINK fatal error LNK1181: cannot open input file 'C:\Program Files\Epic Games\UE_4.20\Engine\Intermediate\Build\Win64\UE4Editor\Debug\Core\UE4Editor-Core-Win64-Debug.lib'

The file is actually missing. Can anyone tell me what I can do to rectify this?

I'm using VSCode. In VS2017 I would have had the option to attach to a running process, but this is not an option in vscode afaik. Even in VS2017 its not working. It would load up the editor, but the breakpoints will not be triggered. Eventhough I did download the debug symbols.

Thanks!

Product Version: UE 4.20
Tags:
more ▼

asked Oct 16 '18 at 05:30 PM in C++ Programming

avatar image

Edregol
169 13 15 26

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Oct 20 '18 at 01:36 PM by Edregol for the following reason:

The question is answered, right answer was accepted


1 answer: sort voted first

I don't know what I did, really. But it works right now. It might be one of the following:

  • Check the "Include Debug Files" checkbox in the project settings, to be able to debug the game with an attached debugger.

  • Run [GameName]Edit (DebugGame) Configuration.

more ▼

answered Oct 20 '18 at 01:36 PM

avatar image

Edregol
169 13 15 26

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question