x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blocky shadows with background mesh

Hi, I'm new to UE4. To save resources, I created a cylindrical mesh and I applied a material (with Emissive and Opacity mask) by modifying an hdr . Directional light passes through the mesh, but it generates blocky shadows on the ground. (Directional light-> static / Skylight-> static). I solved the landscape's problem increasing the "static lighting resolution" but for the static mesh of the building I do not know what parameter to change!

any suggestions?

Sorry for my bad english

SV

alt text

alt text

alt text

Product Version: UE 4.20
Tags:
ue4back.png (2.5 MB)
ue4back3.png (401.2 kB)
more ▼

asked Oct 24 '18 at 02:51 PM in Rendering

avatar image

vensan
1 1 2

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi there! what you are looking for in the static mesh is under the Details -> Lighting tab. You can use "Overridden Light Map Res" to increase the resolution on your static mesh to match the rest of the scene. alt text

more ▼

answered Oct 26 '18 at 03:04 PM

Evan.Doody (suspended)
avatar image vensan Oct 27 '18 at 03:40 PM

Thank you, but I had already tried to increase that parameter, but the problem remains.

avatar image Evan.Doody Oct 29 '18 at 05:19 PM

Oh, yea if its "red" like you are seeing then the lightmap resolution is probably too high and not too low. I would start by trying to lower that until they show as green to match the rest. You may also want to try going into your static mesh and checking on "Generating lightmap UVs." If not set up correctly, it may be taking some bad UVs and generating lightmap UVs will at least help determine if this is the problem

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question