x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cooking Failed: Unknown reason

Hey,

I am trying to cook and package up my project but I keep getting a cook failure: Unknown reason message. I have tried to figure it out but can't find anything to help. I have saved the log to the following location.

https://drive.google.com/file/d/14dP_LLKZQbsIgUmBBXQlLCcQJGqlfWif/view?usp=sharing

Please can someone help?

Product Version: UE 4.19
Tags:
more ▼

asked Oct 25 '18 at 07:36 PM in Packaging & Deployment

avatar image

Rolane
1 1 2

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

There are a number of duplicate errors causing the cook/package to fail. Just from the summary section at the end, I've found:

  1. LogInit: Display: LogPackageName: Error: DoesPackageExist: DoesPackageExist FAILED: <filename> is not a standard unreal filename or a long path name. Reason: Name may not contain the following characters: " " This means you have asset files (.uasset) with spaces in their names. From what I can tell, you have a ton of assets named "filename - Copy". The " - Copy" at the end is a problem because spaces are not allowed in any filename or path by Unreal, to prevent issues on certain platforms. If you need to keep the "Copy" part, I recommend renaming them to "_Copy" instead. I think the spaces in your project folder "Unreal Projects/Dark Legends of Koyannis" may also cause problems due to the spaces, since you aren't allowed to have spaces in a project name when you create it. I recommend fixing the asset name issues before messing with that though.

  2. LogInit: Display: CookResults: Error: Couldn't save package, filename is too long: According to this answer about "filename too long" errors, file paths must be 227 characters or shorter, due to limitations with Windows. I recommend moving your projects folder to the root of the C:/ drive, such as C:/Projects, since the Users/Kieron/Documents/Unreal Projects/ portion adds 39 characters (if my count is correct) on its own, making it harder to work with longer asset filenames/paths.

  3. LogInit: Display: LogLinker: Warning: Failed to read package file summary, the file <filename> is too small (0 bytes, expected at least 32 bytes) This means you have a bunch of empty .uasset files in your content directory, likely from things you deleted that didn't get cleaned up properly. Manually deleting them should fix it, since they contain no data anyway.

  4. LogInit: Display: CookResults: Warning: Unable to find package for cooking <filename> These files can't be found for packaging since they failed to cook. The ones listed are the same ones as issue 1, where they contain spaces. Once you fix that cooker issue, it should fix this packaging issue.

The Error/Warning Summary section I checked for this info near the bottom says it's only showing the first 50 unique errors, all of which are related to the four I covered above with different files. Hopefully fixing what I covered will fix more than 50 errors, since it says you have 4316 errors and 39,677 warnings, although some of those could be duplicates because Unreal really likes to complain when there's an error.

I don't have time to go through the whole log file at the moment, but I'll be around to help should any more issues pop up after you fix what I covered. And I'll try to skim the log file for other issues while you fix these.

I hope you get it working soon! :)

more ▼

answered Oct 25 '18 at 08:21 PM

avatar image

Chromarict
402 2 5 9

avatar image Rolane Oct 26 '18 at 05:32 PM

Thanks soo much for this! I managed to fix most of the errors this way but still got 500. Here are the new logs:

https://drive.google.com/file/d/1xRbOK5M5oeWVaASgBkrkzwzqhTkzYbsx/view?usp=sharing

I am trying to find the reason but I'm not the best at finding them in the long thread.

avatar image Chromarict Oct 28 '18 at 03:31 AM

You're welcome, and I'm glad the first bit helped. 500 is much more manageable than 4300. Onto the new problems, here's what I've found:

  1. Ensure condition failed: !ActorCDO->bExchangedRoles From what I've found on this answer, it seems you have an empty Actor subclass somewhere with a child blueprint, which is causing the ensure condition to fail. Unfortunately you don't have the debugging files installed, so the stack trace for this error doesn't give any useful info. To get the info you need, you'll have to open the Epic Games launcher, click the drop-down arrow next to the launch button for your engine version, and open the options menu. Then, enable "Editor symbols for debugging" and click apply. Once that's done downloading, running the package command should give useful information for error stack traces, instead of just saying "UnknownFunction []".

  2. Error loading .../RecylingBin/*.uasset The cooker seems to be failing to load a recycling bin model and its textures. This may be because you've deleted the files in the editor and it left empty .uasset files behind, or it may be looking in the wrong folder if you fixed the typo of "Recyling" but something is still looking in the misspelled folder instead of the corrected one.

  3. Warning: [Compiler Ue4ASP_Character] InputAction Event references unknown Action 'Crouch' for InputAction Crouch Inside your Ue4ASP_Character class, you're trying to handle an input event named "Crouch" without it existing. You're either missing a "Crouch" input action in Project Settings->Input, or you need to change the input action this class is pointing to.

I'm running out of space since comment sizes are limited, so I'll follow up in replies to this comment as I find more solutions to the errors.

avatar image Rolane Oct 30 '18 at 07:28 AM

Thanks again! I've fixed a few more of the issues and installed the editor symbols. This has helped a lot but still got a lot. I have attached the latest version. https://drive.google.com/file/d/1vP3p_n8dETFiGApsqHsWstWLvF35k9og/view?usp=sharing

Thanks so much for all the help so far! I really appreciate it!

avatar image Chromarict Nov 01 '18 at 04:07 AM

Well you're in the home stretch with only 48 errors left! :D Here's what I've been able to figure out:

  1. Error: Your CDO has had ExchangeNetRoles called on it (likely via RerunConstructionScripts) which should never have happened. This will cause issues replicating this actor over the network due to mutated transient data! I'm not certain exactly what's causing this, but the stack trace says it's happening in the Kismet compiler, meaning somewhere you have a broken Blueprint. Since the stack trace doesn't say which BP is causing this, you'll have to manually check all of your BPs for compile errors. Although if you have Blueprint Nativization enabled, that may be the cause since I've had problems with that in the past. So if that is enabled, try turning it off first.

  2. Error loading */models/Radio/*.uasset! Looks like a similar situation to the recycling bin assets in my last comment. You either renamed, moved, or deleted the radio assets and something is trying to access them. If you did delete them, it's likely old empty asset files you have to manually delete.

  3. Error: [Compiler HeroTPP_AnimBlueprint] HeroTPP_AnimBlueprint - The skeleton asset for this animation Blueprint is missing, so it cannot be compiled! from Source: /Game/DarkForest/vegetation/Player_Assets/Character/HeroTPP_AnimBlueprint.HeroTPP_AnimBlueprint Your "HeroTPP_AnimBlueprint" is pointing to a skeleton asset that has either been moved or deleted. You should be able to fix this by opening the anim blueprint and telling it which skeleton to use.

  4. Warning: [Compiler SpeedFP] Set Input Mode UI Only (Deprecated) is deprecated; Use the new version of Set Input Mode UI Only instead Your "SpeedFP" Blueprint is using a old deprecated node with the given name and wants you to update it to the newer version.

...and I'm out of space again.

avatar image Chromarict Nov 01 '18 at 04:14 AM

The rest of the errors seem to be assets failing to load because they've been moved, renamed, or deleted. Most of these errors seem to be coming from the following directories:

  1. Content/Ocean/ShipsAndExamples/

  2. Content/Foliage/Materials/

  3. Content/Test/models/Mobile_Phone/

  4. Content/NopalsFoliage/

  5. Content/InfinityBladeWeapons/

  6. Content/InfinityBladeGrassLands/

Also, the maps EndBeach and Crystal_Cave seem to be having trouble loading some assets. You should probably open them and check the output log for errors, and maybe even run a Play In Editor session to check for runtime errors.

avatar image Rolane Nov 07 '18 at 04:42 PM

Thanks again for the help! I only have the below one left but tonight I will be going through all my blueprints to find the one.

Error: Your CDO has had ExchangeNetRoles called on it (likely via RerunConstructionScripts) which should never have happened. This will cause issues replicating this actor over the network due to mutated transient data!

avatar image Rolane Nov 09 '18 at 08:28 AM

Thanks so much for all your help! I have managed to build the game now but it crashes whenever I try to launch it from the .exe file... Any ideas? :)

avatar image Chromarict Nov 17 '18 at 06:15 AM

Sorry for taking so long to get back to you. I'm not sure what would be causing that crash. Usually when built projects crash, you can go to the folder you launched it in and go to GameName/Saved/Crashes to check the crash log.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question