x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Visual Studio 2017 on 4.20: breakpoints are not working

In short: breakpoints aren't working, VS2017 says "This breakpoint will not currently be hit. No symbols have been loaded for this document." and doesn't hit the breakpoints at all.

Detailed: Never had any problems with that before to be honest, I tried VS2017 some time before on older versions of the engine and debugging was fine.
Currently I have VS2015 and VS2017 installed.
On VS2017 I have game development packages installed (using VS installer).
The project I'm trying to debug is converted to newer version from 4.18.
I tried creating fresh and clean C++ project, but the breakpoints aren't working there either.
If I look into Modules tab, there is indeed no sign of the current project's pdbs/dlls loaded at the moment, only the engine and the system ones.
So Visual Studio hasn't even tried to load debugging information for the project for some reason, despite it exists (and perhaps built) in the Binaries/Win64 folder (dll and pdb files).
Configuration is set to DebugGame Editor, project compiles, starts and executes debugging just fine.
I tried to remove folders Binaries, Intermediate and 2 others, didn't help.
Full cleanups of the project and recompilations, obviously.
Raised a manual exception (by calling throw at the convenient place) - Visual Studio traced the code to the place where an Actor receives update in the engine code before the project's, 2 stack calls before the KernelBase.dll, the closest of them being UE4Editor---Win64-DebugGame.dll! (yes, I used hot reload for this). It didn't pick up the needed .pdb file automatically.

Why?

Product Version: UE 4.20
Tags:
more ▼

asked Oct 26 '18 at 02:47 PM in C++ Programming

avatar image

HungryDoodles
495 30 25 40

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I should be given a medal for finding the answer in 15 minutes after I posted the question.

It works now.

Never ever work with the projects inside NTFS mounted folder, VS tried to reference \Devices\HarddiskVolume6..., miserably failed.
Basically it means I have 2 SSDs: the new one and the old one. I moved everything from the old one to the new one, but since the amount of disk volumes I have is already 6 I tried to not creating the new volume by creating NTFS folder with the old SSD mounted to it.
And just in case, symlink does not save the day, when I raised the exception in symlink folder I basically got the same message, that it couldn't hook \Devices\HarddiskVolume6...

more ▼

answered Oct 26 '18 at 03:13 PM

avatar image

HungryDoodles
495 30 25 40

avatar image cmwheeler Jan 22 '19 at 12:56 AM

how did you figure this out?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question