x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Plugin DLL not found.

Since upgrading to 4.4 I can't run my project anymore. It consists of one game module and one plugin. The plugin exports some UObject classes to the game module, so it's defined in the module's PrivateDependencyModuleNames.

It builds just fine and worked well in 4.3.1. But now, when opening the editor, it says UE4Editor-MyPlugin.dll is missing. I can find this dll inside the Binaries folder of the plugin directory, but not in the root Binaries folder. I guess that's the problem?

Product Version: Not Selected
Tags:
more ▼

asked Aug 15 '14 at 03:28 PM in C++ Programming

avatar image

lucasncv
259 12 15 28

avatar image Doug E ♦♦ STAFF Aug 15 '14 at 06:54 PM

Hey lucasncv-

We're trying to recreate this so that we can find out the exact cause. What plugin are you using that is causing this problem?

avatar image lucasncv Aug 15 '14 at 07:05 PM

It's my own plugin, I'm trying to isolate the exact problem. I tried switching back to 4.3.1 but the problem persisted... I'm must have corrupted something somewhere. I'll get back to you with more details.

avatar image Doug E ♦♦ STAFF Aug 15 '14 at 07:56 PM

Okay, thanks for letting me know. Let me know what you find and if the problem is something to do with the editor then we will continue our investigation.

avatar image lucasncv Aug 15 '14 at 08:14 PM

Doug, I've managed to isolate the problem to a simple project. It doesn't seem to work in any version, even 4.3.1. Let me break it down:

In MyProjectPlayerController I use two external objects, one from UObjectPlugin (the engine plugin) and the other from MyPlugin (included in the project).

Builds fine, but says MyPlugin.dll is missing. If I remove MyPlugin, everything works.

Why UObjectPlugin works but MyPlugin does not? They're almost identical, I think.

myproject.zip (129.9 kB)
avatar image lucasncv Aug 15 '14 at 08:47 PM

If I set MyPlugin's LoadingPhase to PreDefault, it says MyPlugin was not found and then loads the project anyway. But the second time I load it, it crashes.

EDIT: The test project needed at least one class inheriting from UObject to work correctly.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Figured it out, the plugin needs to load before the Game Module, e.g. LoadingPhase: PreDefault.

more ▼

answered Aug 18 '14 at 08:36 PM

avatar image

lucasncv
259 12 15 28

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question