x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Launch Xcode from UE4 Editor

Hello,

I'm experiencing a very weird issue. While using the UE4 Editor, if I right click on a class or any file with code, Xcode 10 will launch it's main editor window but it will also launch three additional standalone windows of the same file, additionally, it will force focus on itself, disabling me from focusing back on the EU4 Editor or anything else, and I have to force quit Xcode if I want to do anything else. If this wasn't weird enough, once I force quit Xcode, a new standalone window with the same file launches and once I force quit that one, the Xcode open project dialog comes up and I can finally force quit that.

This does not happen if I open the UE4 Xcode project from the Finder app directly and that's the only way I can get any work done. It doesn't happen at all with Xcode as long as I don't launch it from within the UE4 Editor, so I know it has to be related somehow. I have been unable to find any reference of this on any forums and I have no clue what is going on.

My system is:

OS: macOS High Sierra 10.13.6 17G65 x86_64

Host: MacPro5,1(2010)

CPU: Intel Xeon W3690 (12) @ 3.47GHz

GPU: NVIDIA GeForce GTX 980 Ti

Memory: 16GB

Any help on this will be greatly appreciated.

Cheers

Product Version: UE 4.20
Tags:
more ▼

asked Oct 30 '18 at 12:05 AM in Using UE4

avatar image

Wxsabi
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question