Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't get Event Hit to work

For a while I've been trying to get Event Hit to work. I got Overlap to work perfectly but I need Hit instead of Overlap for some of the Event Hit functionality.

I tried everything, found no fitting tutorial. It's pretty straight forward.

This is the projectile collision setting:

alt text

This is the Static Mesh collision setting:

alt text

No collisions are ever detected. What am I doing wrong?

Product Version: UE 4.20
projectile.png (32.1 kB)
cube.png (31.8 kB)
more ▼

asked Nov 03 '18 at 03:53 PM in Using UE4

avatar image

41 3 3

avatar image Hawba Nov 03 '18 at 05:12 PM

What do you mean by "Hit over Overlap"? Are you trying to register both the hit and the overlap events? Actors can either overlap, block or ignore each other, to my knowledge.

avatar image CookieFamous Nov 03 '18 at 05:15 PM

Sorry for not being clear. I meant I was trying to get an "event hit" to work, rather than an "event actor begin overlap".

I just want any of these to go off on the projectile's Actor BP. alt text

gooff.png (70.8 kB)
avatar image Hawba Nov 03 '18 at 05:32 PM

I see. You can't have both hit and overlap. An object can either hit another object or go through it. Take a look at this article about collision, hit events and overlap.

avatar image CookieFamous Nov 03 '18 at 05:46 PM

Thanks. I am familliar with this page and I have read it and followed its instructions.

I now also added collision boxes around both the projectile and the mesh I was shooting at with the exact same settings as shown above.

Nothing seems to work so far.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I'm assuming you are using a custom mesh? Do you have collision setup in the mesh itself? Go into your mesh -> setup collision there and also make sure you have simple collision on the mesh. (Toolbar -> Collision -> add simplified collision).

Also check your physics asset if its a skeletal mesh. You will need to click on the physics volume and make sure your collision is setup there as well. (Also make sure simulation generates hit events is checked in the collision section of your physics asset volume.

more ▼

answered Nov 03 '18 at 05:33 PM

avatar image

Steve SybrSyn
1.5k 4 5 10

avatar image CookieFamous Nov 03 '18 at 05:41 PM

Thanks! Do you mean the Physics Material Override?

This is empty right now. I just made an Actor BP with a "cube" base asset. I added a collision box bigger than the cube itself and set the settings exactly like I showed above.

Nothing changed (it was defaulted on everything set as "block").

Are the settings above okay?

avatar image Steve SybrSyn Nov 03 '18 at 06:31 PM

No you do not need the physics material override for this.

Okay, so you added a collision box bigger then the cube, what are the collision settings on that collision? Because if that collision is blocking the projectile, then the projectile will never hit the mesh, thus never calling event hit.

If you want the collision box to trigger the event hit then you need to set the collision settings on the trigger box and make sure you are using the event hit of the collision box and not the mesh.

avatar image CookieFamous Nov 03 '18 at 06:30 PM

I got a little further.

I made a new project - the first person shooter one. In there, I made an Actor BP with mesh there and it worked. Then I duplicated all of the collision settings into my own project and it does detect hits now.

The big difference is that a collision box is now the Scene Root for the Projectile.

Problem now is: The projectiles no longer move.

When I turn "simulate physics" on in the scene root, it does move, but collisions no longer work. When I turn it on in the Static Mesh as well, it doesn't move nor collides.

What am I missing?

avatar image Steve SybrSyn Nov 03 '18 at 06:34 PM

I do not think you want to simulate physics on the scene root. Are you using the projectile movement component?

avatar image CookieFamous Nov 03 '18 at 06:35 PM

Yes I am. And all the components are set to "movable".

avatar image CookieFamous Nov 03 '18 at 06:43 PM


The projectile just stopped because it hit me. I hooked it up to the rest of the projectile blueprint I already had, made it spawn further ahead of my character and it works now!

All I need to figure out now is how to exclude the instigator from the collision options. I think I'll figure this one out, I've done it before.

Thank you so much for your help!

avatar image Steve SybrSyn Nov 03 '18 at 06:51 PM

No problem, I'm glad you got it working!

The easy way is to just spawn the projectile a bit more forward so that it does not collide with yourself on spawn.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question