Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Build 4.21 Preview 4- Sequencer Still Not Rendering Audio?

Hey, so I posted earlier about how to render sequences with audio in UE4, and was directed to 4.21 as it has the experimental Master Audio Submix option, but after selecting it and rendering the sequence in my file folder I only see one file. And that file doesn't have audio. When I render using the sequencer with audio in 4.21, where does the audio file go? Or is it supposed to be part of the original video? Here are my settings in case I forgot to select something.alt text

Please advise

Product Version: UE 4.21 Preview
more ▼

asked Nov 03 '18 at 09:35 PM in Rendering

avatar image

10 3 4 10

avatar image Max.Chen STAFF Nov 04 '18 at 06:26 AM

You'll need to run with the -audiomixer option at the command line.

avatar image Skystalker382 Nov 04 '18 at 06:21 PM

How do I do that (On a Mac)?

avatar image Max.Chen STAFF Nov 04 '18 at 07:03 PM

There’s some info here on how to enable the new audio system through ini files:


avatar image OoKushoO Dec 07 '18 at 11:03 AM

Hey Guys , I tired Doing the Above steps and i Could Listen Audio being Played while Rendering , But i do not see any Audio file , there is one video File , and it does not have any audio in it , Can anyone please help me with this , I do not know if Audio is Actually rendering , if it is rendering , is it going to embed inside the Video file or it will be a separate file . Please help alt text

camerasettings.png (73.4 kB)
avatar image Skystalker382 Dec 08 '18 at 10:11 PM

Yes I have the same problem and even after attempting to follow the instructions the engine has yielded no results. If anyone has a fix or if we are missing something please tell

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

after a month of trying - having looked at yr screenshot - i tried again and it worked ! my only difference is i have -audiomixer in "inherited" too , and ddid 4.21 update yesterday. tho for the whole last month, renders have been outputting an empty .wav file as well. if it works for you, you will have yr audio in a .wav in same directory. good luck !!

more ▼

answered Dec 09 '18 at 05:46 PM

avatar image

31 3 1

avatar image Skystalker382 Dec 09 '18 at 09:50 PM

Thank you so much

avatar image OoKushoO Dec 10 '18 at 05:30 AM

Hey Guys , Iam glad that you have found your way ,Although i was not able to do it , I could listen the audio while the rendering is being Completed . but i could not Find any files , Could you guys please let me know the whole process you have done to achieve it . Thanks

avatar image stoppedclock Dec 10 '18 at 12:17 PM

https://www.youtube.com/watch?v=Bn5_5Gtb6QM&list=PLv5rEvssQBJIxTEU7BDdb-uu88kmHoSZs this guy takes u thru the set-up, must be latest 4.21 at that point i was getting empty .wavs alongside my AVIs ...and left it a while as I realised i was just becoming obsessed..... all i changed yesterday was -- ue4.21 update, changed my player to VLC, and added "-audiomixer" in those checkboxes in render settings, and " render in seperate process"......

avatar image OoKushoO Dec 10 '18 at 12:48 PM

Hi StoppedClock thanks for the reply i have tried your steps . but still no luck iam not even getting the Empty .wav files , I have tried the above setup and nothing happens , I have some questions :

1 . Are you playing your audio files through sequencer Audio Track or any other way . 2 . What OS are you using ?

Do i have to setup anything else first in windows in order to run this for unreal , Please help i have stuck on this for a month Now .

avatar image stoppedclock Dec 10 '18 at 03:18 PM

frustrating i know !! yes ,seq audio track windows 10 no GPu - so my laptop is not better than yrs !!

the clue for you is that I have always had the .wav - it was just always empty. Do you have any other programs that output audio to see that yr computer does render audio?? otherwise i wd say that you just have to go thru it all - slowly 1 - again.....once we have been thru these processes many times, it is easy to do 90% and miss one thing. the plugins will sometimes turnoff if you update etc - things like that. At the moment my windows ini file looks like this... [Audio] ;AudioDeviceModuleName=XAudio2 ; Uncomment below (and comment above) to use multi-platform mixer module by default AudioDeviceModuleName=AudioMixerXAudio2

; Defining below allows switching to audio mixer using -audiomixer commandline ;AudioMixerModuleName=AudioMixerXAudio2

avatar image Skystalker382 Dec 10 '18 at 03:43 PM

I am using Mac OS Mojave. OoKushoO at first I too did not have any WAV file, and I was stuck for a long time. Don’t give up! Look, I see what you’ve done incorrect. You wrote -audiomixer in the wrong place. First scroll till you see and check the box that says “Use separate process.” At that point add -audiomixer in the additional command line argument box and the inherited command line argument box. Make sure you name the file where it says Audio file name, and give an output folder for the video in general. Good luck! I hope you make it :).

avatar image OoKushoO Dec 11 '18 at 07:00 AM

Hey StoppedClock and SkyStalker382 , Thanks for your feedback , But i am not able to do it , and i Do not know what is happening , Let me tell you my Steps What i have done to achieve it .

  1. First i Change the WindowsEngine.ini file to this -- image 1

  2. Then i Open the Editor Using -audiomixer commandlineArgument -- image 2

  3. Then i Enable plugins Sounds Utilities and Synth

  4. After that i render the Sequencer Using these Settings , -- image3 , image 4 alt text i Can hear audio playing but i cannot see any audio file .

Iam gonna attach some more ScreenShots , i do not know if they are usefull .

And if there is anyother way that i could debug this problem ,

As StoppedClock said
" Do you have any other programs that output audio to see that yr computer does render audio?? " What does this mean , Does Windows need to configure first to give audio Renders .

image1.png (50.8 kB)
image2.png (16.3 kB)
image3.png (75.9 kB)
image4.png (76.3 kB)
image5.png (23.9 kB)
avatar image stoppedclock Dec 13 '18 at 01:04 PM

i mean; do you have video editing software that outputs audio to check that yr computer is doing that ok

avatar image stoppedclock Dec 12 '18 at 04:11 PM

one trap is that if you do the -audiomixer in the desk shortcut, remember to start with a space !

avatar image OoKushoO Dec 26 '18 at 06:43 AM

Thanks stoppedclock and skystalker382 for your help , now iam able to render out the Audio Files . Issue was, you have to let the renderer to complete the rendering process , if you press stop Capture , it wont generate any audio file .

avatar image OoKushoO Dec 27 '18 at 05:24 AM

Hey Guys , Now iam able to render out the audio files too . But i have noticed the audio file is always shorter than the video file , If the video is of 17 seconds then audio file will be 7 seconds , I have tried this on my current project and on an empty project , both project gave me same results .

Now i want to know the details of setting up the audio system so i can get full audio renders .

avatar image Skystalker382 Dec 27 '18 at 05:35 PM

Same problem actually. What I did was because I was just running a waterfall scene I put the track in twice with the second one playing in reverse (in a separate video editor) and blended them.

avatar image christopheraugustus Feb 07 '19 at 01:57 PM

Same problem here using the latest UE 4.21.2: .wav file contains only the first 2 seconds of a 1 minute movie capture.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question