x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to use 'Datasmith' (OR: is it even a thing anymore?)

I have tried forever to try, or use, or find out ANYTHING about this 'Datasmith' it simply does not work! I can export *.uDatasmith from 3dsmax. But: Unreal can not see it or know what it is at all.

I do the only available, (seriously out-of-date) tutorial, they say: Go to the plugins panel and Check to allow 'the 7 datasmith plugins' - I see only one called: 'Datasmith Content' (in both 4.19 and 4.20) , BUT it is already enabled (in both 4.19 and 4.20) It says there will be a big Datasmith button to 'import' (like File/Import is not good enough??)

BUT THERE IS NO 'DATASMITH' BUTTON ANYWHERE ON MY UNREAL!! (4.19 or 4.20)

SO WHAT GIVES?

This is how it goes with every single thing I have tried in unreal. It doesn't work, tutorials are useless and out of date, I get no answer at the forum... This lackluster lack of caring or quality,. can only continue so long before Lumberyard takes over (or Unity gets Blueprints, .... That would KILL Unreal..)

Product Version: UE 4.20
Tags:
more ▼

asked Nov 06 '18 at 07:58 AM in Using UE4

avatar image

NextWorldVR
0 2 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello.

The first thing I need to ask is; are you using a Windows PC? Because Datasmith is not supported on Mac.

Second, on the Epic Games Launcher, go to the Library tab, and under the 4.20 engine slot, click "Installed Plugins". Confirm that Unreal Datasmith is already installed.

If it is not installed, then scroll down the Launcher page until you see the Unreal Datasmith plugin listed, and install it to the engine.

When Datasmith is installed, inside of the Editor plugin options under Unreal Studio, you should see more than just the one "Datasmith Content" option.

More details are available here: https://docs.unrealengine.com/en-US/Studio/Datasmith/HowTo/DownloadandInstall

more ▼

answered Nov 07 '18 at 03:19 PM

avatar image

Stephen Ellis ♦♦ STAFF
11.5k 322 32 480

avatar image R Sunfire Dec 17 '18 at 02:57 PM

What if our library tab only has "shop games and mods"? The tutorial referenced in the answer shows a "unreal datasmith" already in library. Mine isn't in the library and when I search for it it doesn't come up. The only time I can see it is in the demo's that tell me what I'm looking for.

avatar image Stephen Ellis ♦♦ STAFF Dec 17 '18 at 03:07 PM

There has been a very recent change to the Epic Games Launcher that added a new "Library" page which is unrelated to the Unreal Engine.

You need to first click on the 'Unreal Engine' tab, and then along the top row you will see a second 'Library' tab. This is the correct one for you.

avatar image R Sunfire Dec 17 '18 at 04:04 PM

I can't find it there either. Clicking Installed plug in's says I have no plug in's installed.alt text

snip.png (158.2 kB)
avatar image Stephen Ellis ♦♦ STAFF Dec 17 '18 at 04:05 PM

It looks like you have not joined the Unreal Studio free Beta: https://www.unrealengine.com/en-US/studio

After you join, the option to install Datasmith will be added to the Launcher

avatar image R Sunfire Dec 17 '18 at 04:18 PM

Thank You!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello! I had the same problem and added to your comment below. I found out that I had not signed up for Unreal Studio Beta. As soon as I signed up on the website https://www.unrealengine.com/en-US/studio Datasmith showed up in the Library.

more ▼

answered Dec 17 '18 at 04:38 PM

avatar image

R Sunfire
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question