Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Remote build for iOS permission denied after build command

Hi there,

I've been struggling with getting past this issue for some time with my remote builds for iOS using a mac mini as the remote builder. This issue began after I had already had already gotten past the point of build command and received an error about the certificate on the Mac side missing the private key.

I generated a new SSH key from the project settings window, received no errors (and continue to have no errors there), but now every single time I try to build I am hit with this: "ERROR: Failed to run init commands on remote server isg-macmini. Output = Permission denied (publickey,password,keyboard-interactive)."

I have tried every solution posted to answerhub, including changing the permissions on the .key file generated to full control for only the USERS group, moving the .key file to a different directory and overriding the location in project settings and every other answer I could find on this topic.

Does anyone else have any idea what could be the cause of this? Is it possible that the lack of private key on the Mac is related? It's very difficult to tell when I just receive this error no matter what. The only other error I have received is because of too lax protection on the .key file, which is simply fixed, but just returns back to the Permission Denied error mentioned earlier.

Would really appreciate any help on this.

Product Version: UE 4.20
more ▼

asked Nov 06 '18 at 02:58 PM in Packaging & Deployment

avatar image

The Scanner Darkly
70 6 11 14

avatar image cream-scxr Nov 07 '18 at 10:50 AM


You're not alone. We're struggling with the same issue (I believe), trying to remote build an AR test-project (AR Blueprint Template) on MacBookPro (Mojave) from PC (Win10) with UE 4.20.3 (built from the source, Oculus Version). We also tried the solutions you mentioned above with no success. The Error occurs after this command:

Doing date +"%s" && sysctl hw.memsize | awk '{print $2}' && sysctl hw.logicalcpu | awk '{print $2}'
Execute took 00:00:00.2209741
ERROR: Failed to run init commands on remote server macbookpro. Output = Permission denied (publickey,password,keyboard-interactive).
(see D:\GitHub_Repositories\UnrealEngine-OVR\Engine\Programs\AutomationTool\Saved\Logs\UBT-ARTest_One-IOS-Development.txt for full exception trace)

And here is the corresponding UBT-ARTest_One-IOS-Development.txt for more details.

We would also appreciate any help on this issue. Thanks. :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question