x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Material seems inverted on destructible mesh

I have an imported FBX mesh from zBrush. It imported without anomalies or error messages of any kind.

I have a very basic material applied to the mesh (which I turned into a destructible mesh using the Apex plugin)

I have a very simple test environment setup where if I press the (1) key on the keyboard, damage is applied to the mesh and it crumbles correctly.

Here's my problem.

The material I have applied looks like a marble-blue. With the material applied the mesh simply takes on a monotone light blue color(Not correct) but when I destroy the mesh and it crumbles, the insides appear correct, as the marble-blue material.(Not the monotone color.)

I have no idea what is causing this. I can upload screen caps if need be. Any help would be greatly appreciated.

Cheers.

Edit:(I've added Screenshots) Monotone Color (incorrect) alt text

Destroyed Mesh (Correct Color) alt text

Product Version: UE 4.20
Tags:
monotone.jpg (826.2 kB)
correctcolor.jpg (901.8 kB)
more ▼

asked Nov 07 '18 at 04:22 AM in Rendering

avatar image

thangor
46 1 1 4

avatar image thangor Nov 07 '18 at 10:34 PM

Is this something super simple that I'm overlooking?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Destructible meshes and their materials appear to be acting ... off ... in 4.20. That said, where the solution SHOULD be is in the destructible object itself. If you double click to open it, you can set the material options under the Destructible Settings tab. It may also be that the Interior Element index is reversed which will be under the fracture settings at the bottom.

alt text

You should also be able to select your mesh in the scene and reverse the materials in the details window. If none of these work, it may be due to some apparent problems with the destructible plugin at the moment.

more ▼

answered Nov 08 '18 at 04:32 PM

avatar image

Evan.Doody
191 3 3 3

avatar image thangor Nov 08 '18 at 09:04 PM

Evan,

Totally appreciate the response. I tried rearranging the element index to no avail. Tried changing around the material options as well. Even reimport the FBX file. no luck.

Thanks again though for the response, greatly appreciated!

Regards

avatar image ISmellDoody Nov 08 '18 at 11:34 PM

Has to be a bug in the current engine then. You may want to try setting up the same scene in 4.17. I was able to have success there. Sorry we couldnt solve it for you. The "Milky" color may actually just be a strand of the light color from your marble. You could try increasing the UV scale on fracture parameters.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

It was the Normal map. I was simply overlooking the fact that I had no normal map on my Marble (lerp'd) material.

After adding the normal map I had to change the resolution around do the UV options. Sadly, I op'ted for a low poly model so the resolution wasn't good enough to justify having a blended material. But, for anyone else out there that happens to stumble across the same issue..... CHECK YA NORMAL MAP BRAH!

regards.

more ▼

answered Nov 11 '18 at 06:06 AM

avatar image

thangor
46 1 1 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question