x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Building UE4 project with CI (Jenkins) doesn't produce an executable (.exe)

I have set up batch files to build my UE4.20.3-release project with Jenkins. I compile first, then build the project, and finally cook the files and package for Win64 & Development. Packaging on my local machine works fine, when using packaging > Win64. Other projects seem to build fine on the same server. My project only produces a single PAK-file in PROJECT_NAME/Content/Paks/. Here are the build logs: Development, Shipping.


Batch files (split up in stages to push build notifications to Slack):

  1. UnrealBuildTool.exe -projectfiles -project="%2" -game -progress

  2. msbuild.exe "%2" /t:build /p:Platform=Win64;Configuration="Development";verbosity=diagnostic

  3. UnrealEngine-4.20.3-release\Engine\Build\BatchFiles\RunUAT.bat BuildCookRun -build -project="%2" -allmaps -noP4 -platform=Win64 -clientconfig=Development

  4. UnrealEngine-4.20.3-release\Engine\Build\BatchFiles\RunUAT.bat BuildCookRun -cook -project="%2" -allmaps -nop4 -platform=Win64 -clientconfig=Development -nocompile -pak -package -stage -archive -archivedirectory="%3"


When packaging is done, all I have inside the WindowsNoEditor folder is a folder with the project name and a single PAK file inside. No executable or Manifest_DebugFiles_Win64.txt, nor Manifest_NonUFSFiles_Win64.txt and no Engine folder.

I have tried other options for the cooking stage (4.), but it results in the same single PAK file. I have tried different options for packaging within the editor, which end up in DefaultGame.ini. Build logs here.


Things I've tried:

  • Adding serverconfig doesn't help

  • Adding prereqs doesn't help

  • Adding cpp source files instead of just having an empty Source folder doesn't help

  • Removing -package param doesn't help

  • Updating VS (VS2017) doesn't help

  • https://answers.unrealengine.com/questions/814028/view.html Answers didn't help

Any suggestions as to how to produce an executable or to improve the build steps for Jenkins is very much appreciated!

Product Version: UE 4.20
Tags:
more ▼

asked Nov 07 '18 at 01:47 PM in Packaging & Deployment

avatar image

Byrkoet
1 2 3

avatar image mcleary Nov 07 '18 at 02:28 PM

What is the build log for each configuration?

avatar image Byrkoet Nov 07 '18 at 03:23 PM

https://pastebin.com/g2XMkvtB This is for Win64 Development

avatar image Byrkoet Nov 09 '18 at 02:31 AM

https://pastebin.com/GUWffjwv This is the shipping build

avatar image mcleary Nov 11 '18 at 11:22 AM

Unfornutaly I cannot see anything wrong with your build. The binaries were supposed to be where they should be. Are you sure this is not an issue with the job configuration?

avatar image Byrkoet Nov 12 '18 at 01:22 AM

It seems to be an issue with the fact that the building process is split into parts. I have tried building everything all at once and it produced a binary, I'll try to do some tests and post a solution.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question