x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal only reads C++ classes with Visual Studios 2015

Hello, as mentioned in the title, whenever I try to open a C++ class on Unreal, it will always try and open it in Visual Studios 2015. Normally this wouldn't be an issue, but my license for 2015 has expired whereas my license for 2017 has not. I have gone into the settings and set the default program for C++ classes to be Visual Studios 2017 and have saved that setting multiple times. Whenever I attempt to open a C++ class it will pop-up in the bottom right corner of the screen saying that it's loading Visual Studios 2017, yet the program that opens is 2015. Normally my method for an issue like this would be just to delete Visual Studios 2015 from my hard drive since it no longer serves a purpose, however while researching the answer to this question I found that apparently Visual Studios 2015 is required to have the Unreal Engine run properly since it relies on some of the files that 2015 has. Whether this is still true or not I'm uncertain but I thought before doing something as potentially dangerous as that I'd reach out for a response here first.

Product Version: UE 4.20
Tags:
more ▼

asked Nov 08 '18 at 11:51 PM in C++ Programming

avatar image

Jared Bronstein
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi. Unreal Editor -> menu Edit -> Editor Preferences -> General -> Sourse code -> set "Visual Studio 2017".

more ▼

answered Nov 09 '18 at 03:26 PM

avatar image

GS_Aero
11 2 3

That is what I had originally tried to fix the issue. Every time I open up the project I double check and it's always set to Visual Studio 2017 but it will only ever load 2015

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question