x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Deferred Decal has no specular control, yet affects specularity

We all know deferred decals are extremely lacking in UE4, but is there a way I can disable or set the specular value of a DBuffer Decal to zero? I cannot get decals to blend well with anything when they have a predefined specular value which makes them not blend in with the environment. It appears that the specular value of deferred decals is forced to 1.0.

You can see here how the decals (the paths) dont blend with the lighting of the terrain. alt text alt text

and with specular buffer visualization you can see the incorrect values. alt text alt text

Product Version: UE 4.21
Tags:
more ▼

asked Nov 12 '18 at 08:32 AM in Rendering

avatar image

Shirk
240 41 52 63

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey there! You should be able to adjust the specular value by changing the decal blend mode in the material:

alt text

The blends modes of Translucent and Stain should both be able to accept a Specular value for you to adjust and match. Some of these blend modes don't appear to be 100% as expect though, as setting it to Color only still creates a spec value of 1, while Normal Only seems to correctly only effect normals, odd. Hopefully you can get the correct effect you are desired by changing to Translucent Blend mode.

more ▼

answered Nov 13 '18 at 04:48 PM

Evan.Doody (suspended)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question