x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Using too much VRAM on Linux crashes Editor

Most recent crash info

Behaviour: When UE4 runs low on VRAM when running in Vulkan (now the default on Linux), the editor crashes.

Expected: When the editor runs low on VRAM, it takes some kind of steps to reduce VRAM usage (In OpenGL it appears to drop the framerate, but I'm not sure what happens exactly behind-the-scenes).

Notable error line: [203]LogVulkanRHI: Error: Out of Device Memory, Requested=16384.000000Kb MemTypeIndex=7

My setup that probably contributes to the issue: Antergos Linux (Arch)
3x 1920x1200 screens attached
GeForce GTX 760 (2GB VRAM) with 410.66 drivers (also tried with 396.54.09) 24 GB of normal RAM A fair number of running programs

Steps to reproduce:
1. Use plenty of VRAM (In my case, I had a few browser windows open, probably a video playing, as well as Steam and a few Discord windows open. I monitored the VRAM usage in a terminal window with nvidia-smi
2. Open Unreal Engine 4.21 editor with Vulkan, and open a project (In my case, the Twin Stick template)
3. Once the editor's finished opening, try to push it to use more than 2GB of VRAM (2GB being the limit on my system), such as by expanding the editor window, but I've also crashed it a few times by trying to access Blueprints or other engine features.
4. The engine crashes once it attempts to exceed 2GB of VRAM.

Product Version: UE 4.21
Tags:
more ▼

asked Nov 12 '18 at 12:44 PM in Linux

avatar image

Baguettedood
3 1 2

avatar image y19 Jan 29 '19 at 03:25 PM

Same problem with UE 4.22.

OS: Ubuntu 18.04
GPU: GTX 660 2GB (driver 410.48)

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Found the solution in another thread.
Running with -opengl4 solved the problem.

$ ./Engine/Binaries/Linux/UE4Editor -opengl4

Although it is mentioned in the documentation, the problem is not obvious.

more ▼

answered Jan 31 '19 at 11:53 AM

avatar image

y19
21 1 2

avatar image Baguettedood Jan 31 '19 at 12:05 PM

That is indeed what I do so I can continue using UE4. Hopefully Epic will improve the Vulkan renderer in the future so this will not be needed.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question