x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Aim offset problems (Animations clipping/rotating incorrectly)

So before I check myself into a mental hospital I figured I should make one last attempt at solving this aim offset issue of mine.

I've tried for so long I can't even remember when this all began. I have looked countless times at the Owen content example and recreated it, but all I got was strange behaviors and clipping as the character moved around and attacking caused the arm to go in the wrong direction. My best attempt is this one: http://pahlavan.se/dump/2014-08-16_14-52-04.webm

Which is based on the shootergame project where Epic themselves aren't even using an aim offset file for some reason. But as you can see, the arm doesn't point in the right direction when attacking, so you have to look up into the sky to attack forwards and the arm is flipped inside itself for some inexplicable reason. I'm starting to think the animations are at fault here and not the blueprint, since it is almost identical to what Epic made themselves, yet it refuses to work properly.

Here is a picture of my current anim graph, utilizing the method used in the shootergame example.

alt text

If anyone is experienced with aim offsets then I would greatly appreciate some help, because I am slowly going insane.

alt text

Here is also a picture of the settings I'm using for my aim offset poses, they are based on the idle animation that I made and when I animated them in Maya they also had a frame from the idle animation as a base. I had the t pose as a base before but doing this solved some, but far from all issues.

This aim offset is essential for our game and I've looked everywhere, content examples, documentation and other places on the internet to no avail. So if anyone has an idea, then please reply and if you need to take a look at some other blueprints then I can upload more pictures and video.

Product Version: Not Selected
Tags:
more ▼

asked Aug 16 '14 at 01:06 PM in Using UE4

avatar image

Torabi
54 6 10 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Torabi, Sorry you've been beating your head against this. First, can you try switching the Additive Anim Type on all of your Aim Offset poses to 'Mesh Space' (instead of the current local space).

Also, I understand you are copying the shooter game setup where a regular blendspace node was used instead of the dedicated aim offset one, but using an aim offset node is the cleaner, better method. When shooter game was set up, those aim offset nodes probably didn't exist yet.

Either way, your poses need to be additive Mesh Space.

Good luck!

more ▼

answered Aug 21 '14 at 12:36 PM

avatar image

Ray Arnett STAFF
1.4k 45 17 71

avatar image Torabi Aug 21 '14 at 01:25 PM

Forgot to mention that I have tried that too. The only reason I put them on local space is because they won't work with the blendspace method otherwise.

It looks like this when using the aim offset 1D file: http://pahlavan.se/dump/2014-08-21_15-02-05.webm

I'm starting to think the problem lies with my animations but I can't figure out what. Especially my attacking animations that can either only point forward when I force mesh space rotation blend in my layared blend per bone node, and if I turn it off the arm flips up like it does in the videos I posted.

I have also tried to recreate the owen third person blueprint method. But sadly that didn't work for me either.

The problem really has to lie with how I try to blend my attacking montage with the aim offset. I have yet to find a content example where an attack animation is used with an aim offset.

This is my original attempt: alt text

The R_Arm slot comes from my casting montage and the blend pose 0 pin in the layared blend per bone is from the clavicle_r bone and down the arm.

Feels like I am missing some essential blending step. Here is another attempt. http://pahlavan.se/dump/2014-08-21_15-22-24.webm

If I'm ever going to become a proper animator/technical animator I should really try and solve this.

avatar image Torabi Aug 21 '14 at 01:27 PM

I'm really trying to show as much as I can in hopes of solving this. But it is rather hard to show it all without covering an entire monitor with text.

avatar image Ray Arnett STAFF Aug 21 '14 at 01:41 PM

Does your montage play correctly if you completely unhook the aim offset? Likewise, does the aim offset seem to work correctly whenever the montage isn't playing?

A couple other things to look at: Are you using Mesh Space Rotation Blend in your Layered Blend Per Bone node? Also, the animation that is being used in your montage isn't set to additive is it?

avatar image Torabi Aug 21 '14 at 02:06 PM

The montage plays fine without the aim offset but then you can only attack forwards. Which isn't surprising. When I'm not using the aim offset I use mesh space rotation blend so that the arm at least always points forward instead of rotating with the torso of the character. I tried disabling it when the aim offset was plugged in.

The animations in the attacking montage was set to additive. I disabled that now.

I'm currently in my backup project where I mess around with animations. Things got a bit messy but so far both the attacking and the aim offset work fine independently. Managed to get back to my previous best attempt that I didn't show before because I thought it was lost: http://pahlavan.se/dump/2014-08-21_16-02-44.webm I apologize about the terrible framerate in the video, ShareX is giving me a hard time for no good reason. But hopefully the problem is visible.

Standing still the aim offset is fine, when running it clips through the body it seems but that is probably just problems with my animation. The main issue is that the arm flips upwards when attacking. The behavior is the same when mesh space rotation blend is off in the layered blend per bone node.

Feels like I am missing something very trivial.

avatar image Torabi Sep 09 '14 at 06:44 PM

Maybe it has something to do with how I export the animation? Jeremy Ernst said on his series about A.R.T. how you are supposed to export the animations with Quaternion Slerp. But I animate with Euler within Maya, maybe something crews up there?

Been a while since I posted this question but I've been busy moving to my new university.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question