x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Physics Collisions have changed when switching to 4.20

So i have been using version 4.19 for a little while now, and prior to that i was using 4.18. During my time on those versions i managed to get the physics in my game to somewhat acceptable when it comes to the collision my player pawn has when rolling over seams of connecting tiles. I was able to remove the majority of this by reducing the minimum and maximum contact offset values in the physics tab of the project settings. This was done in 4.18, and when migrating the project to 4.19, everything was fine. Now i have migrated to 4.20 and all of a sudden i have the issue of colliding with connection seams despite my contact offset values still being really low.

I double checked by opening up my 4.19 project and testing, and then migrating it to 4.20 again without changing a single thing and it starts occurring.

Does anyone have any insight into why this may be happening? i would rather not have to revert back to 4.19 as the reason i upgraded to 4.20 was to make use of a plugin only available in 4.20.

Thanks in advance!

Also, here is a video showing the issue in action in version 4.20: https://youtu.be/yeRtJUNK3K0

Product Version: UE 4.20
Tags:
more ▼

asked Nov 16 '18 at 11:22 PM in Bug Reports

avatar image

Hairy Cabbage
6 2 4

avatar image Jeff A ♦♦ STAFF Nov 20 '18 at 10:16 PM

Hello,

We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://epicsupport.force.com/unrealengine/s/

Thanks

avatar image dysplaced Jan 08 '19 at 06:02 PM

Hi, I've come across the same problem. I also need to tune my contact offset values in order to get correct collisions for small objects. This worked fine in 4.19, but in 4.20 and 4.21 it does not work anymore. After some experimentation, I found that the values I enter in the project settings don't appear to make any difference in the newer Engine versions, the problems remain exactly the same as with the default values.

Did you find a solution, or manage to get a bug accepted?

avatar image Hairy Cabbage Jan 08 '19 at 11:30 PM

I just ended up reverting back to 4.19 because i had no clue of any fixes. If you do happen to find a solution though please do let me know!

avatar image dysplaced Jan 16 '19 at 08:08 PM

I submitted a bug with an example project and it got accepted: https://issues.unrealengine.com/issue/UE-68523

No target fix yet though, you can vote for it.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question