x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Collisions imported twice

Hello. When I import my mesh from Blender, I get all collisions doubled. What may cause this? Another thing is... How complex my hull can be? I need pretty precise collisions for my project, so my UCX is a bit complicated, but all shapes are hulls. Second thing is that when I use to much meshes in one blueprint, collisions seems to work really bad. Some parts of mesh has collisions, some not. Is there any limit of collision primitives, or something? I will be very grateful for any help :D

Product Version: UE 4.20
Tags:
more ▼

asked Nov 17 '18 at 12:19 AM in Using UE4

avatar image

Actuss
25 2 2 6

avatar image Leo.Archiact Jan 11 '19 at 06:44 PM

Same here, did you find a solution for that?

avatar image JusticeArts Jan 11 '19 at 07:31 PM

Same here, and tested on 2 computers. All my custom collision using UCX prefix imports twice the amount. Doesn't matter if the imported file is new or old. I've also tested multiple versions of the engine as far back as 4.17 and even loaded old projects from years ago all of which now import collision twice the amount.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

I found some kind of solution. First I was thinking, that problem may be in "smooth shading" option. When you have flat shading, it can double number of verts. Changing model to smooth shading gave nothing, so it was not this, but I still think it may be something wrong with that.

Anyway... Like samh-v1 said... When I reimport my mesh with "Combine meshes" option turned on,everything is OK.But I needed to triangulate my collision mesh first, otherwise it imported only few collision primitives. Now everything seems to work fine.

more ▼

answered Feb 14 '19 at 12:58 PM

avatar image

Actuss
25 2 2 6

(comments are locked)
10|2000 characters needed characters left

I believe this is a known bug that is could be resolved in UE4.22. As a work around, I discovered that if you check the "Combine Meshes" box for the import, the collision is imported a single time. Of course, this will only help if your project's workflow allows you to import each FBX as a solitary mesh.

more ▼

answered Jan 12 '19 at 12:13 AM

avatar image

samh-v1
1 1

avatar image JusticeArts Jan 12 '19 at 08:16 PM

Thanks for the response. Sadly the assets that I'm currently trying to import have custom LODs as well. Which the "Combine Meshes" workaround actually triples their collision. I am relieved though that I'm not the only one dealing with this issue, so I can stop stressing on my end and work on other areas of my project. Thanks again and I will wait patiently for a fix.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question