x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Ruler shows incorrect length in 4.4

The ruler (press mouse wheel) is showing an incorrect length when measuring in top/front orthographic viewport if the mouse position is over BSP. This seems to be a regression of 4.4 as it did not happen in 4.3.

How to reproduce:

  • Create a new level

  • Choose 'Empty'

  • Place a simple Geometry->Box in the level

  • Use ruler (press mouse wheel) starting from inside the BSP box

  • The shown length is incorrect

alt text

Product Version: Not Selected
Tags:
ue440_ruler.jpg (163.0 kB)
more ▼

asked Aug 16 '14 at 10:43 PM in Bug Reports

avatar image

stfx
61 6 5 11

avatar image McQuiggle Aug 17 '14 at 09:17 PM

Yeah this is kind of frustrating. Happens whenever you start dragging it over any mesh or bsp in the level. Still works fine in empty grid space though.

avatar image awilliams1701 Aug 24 '14 at 06:04 PM

I can confirm this issue as well. Its only a problem inside BSP. Doesn't seem to be an issue in empty space. It was not a problem until 4.4

avatar image Megasporwic Aug 30 '14 at 06:18 PM

This should be #1 thing to be fixed! The editor is Now Broken! Wow!

avatar image Nico Sep 07 '14 at 08:27 AM

Works correct if isolated (show only selected) some object in ortographic view and with empty viewport. With all scene complete doesn't work.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hello,

Thank you for your report. I have personally entered a report for this issue after running into it. It has since been evaluated and assigned out. Let me know if you encounter any other unexpected behavior.

-Alexander

more ▼

answered Aug 18 '14 at 01:49 PM

avatar image Alexander Paschall ♦♦ EPIC Sep 09 '14 at 06:42 PM

As an update to this issue, I wanted to let everyone know that it has since been fixed internally. This change will be in a future release of the engine.

(comments are locked)
10|2000 characters needed characters left

Any updates on this? I just upgraded to 4.4.1 today and noticed this immediately.

more ▼

answered Sep 07 '14 at 01:21 AM

avatar image

Skisma
63 7 12 15

avatar image awilliams1701 Sep 07 '14 at 03:44 AM

It was already present in 4.4.0. It was not fixed in 4.4.1 preview. I haven't seen any indication if it will make the final 4.4.1 or not. And its been driving me nuts.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question