x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Some sort of "tearing" visible when running ParticleEffects Demo with Vulkan

I've looked at the particle effects demo with Vulkan in 4.21, and I have not done any performance testing, I only packaged the demo in Shipping config with D3D11 and Vulkan APIs enabled, and then compared how it feels to run the resulting exe regularly, and with -vulkan.

I feel no performance difference, likely because both are running into the default VSync, GPU usage is at ~55% with both D3D11 and Vulkan. Both feel nice and responsive.

There is only 1 difference: With Vulkan, there is visible "tearing". Very easy to reproduce. Position the camera here:

alt text

And then use the A and D button to move the camera left/right. There are "lines wandering through the image up/down".

Is this a known issue @RCaloca ?

Using Win10, GTX 1080, 416.X driver.

Product Version: UE 4.21
Tags:
more ▼

asked Nov 20 '18 at 03:40 PM in Bug Reports

avatar image

John Alcatraz
1.2k 57 137 125

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey John, any way you can make a small video showing? I haven't been able to repro here. Are you running fullscreen or windowed?

more ▼

answered Nov 20 '18 at 04:01 PM

avatar image

RCaloca STAFF
258 4 3 5

avatar image John Alcatraz Nov 20 '18 at 04:14 PM

It's switching to fullscreen by default, so that's how I run it.

I just tried to record it using Shadowplay, but the issue is not visible on that recording. So I guess I'll have to try to capture it with my phone :)

avatar image John Alcatraz Nov 20 '18 at 04:34 PM

@RCaloca

Here, I've recorded a video with my phone that does show the issue:

https://drive.google.com/file/d/1Q4NH9HQWrBjasoTbYwqYRCxiWDzCI8va/view?usp=sharing

I have recorded in 120 fps and slowed it down to 33% speed.

Quality isn't great, but you clearly see the tearing. I know filming a 60 hz panel with a 120 fps camera in general isn't ideal - but I can definitely not see anything like this when running it with D3D11 instead of Vulkan, that's perfectly smooth. So it's some issue with the rendering by Vulkan.

avatar image RCaloca STAFF Nov 20 '18 at 08:12 PM

Got it; that's tearing due to vsync. If you do r.vsync 2 it goes away. We'll investigate, thanks!

avatar image RCaloca STAFF Nov 20 '18 at 08:14 PM

Entered internal issue UE-66777 to look into.

avatar image John Alcatraz Nov 20 '18 at 08:32 PM

Great! Happy to hear it wasn't a known issue yet, so that it was actually useful for me to report :)

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question