x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Problems switching between ARSession and non-AR session

So I have an app in Unreal where I have essentially two game modes. One game mode the user is in a non-AR state moving around the scene with their finger. The other game mode simply places an object onto a plane in an ARSession. The problem occurs when I go from the AR mode to the non-AR mode.

Essentially, when returning to the non-AR mode the camera is off somehow by a pretty noticeable amount. However, I don't know why it is even being affected considering it is using a different pawn/player controller and different game mode as well as level. It is almost as if the camera changes position, rotation, zoom, and FOV and possible even more. I've tried resetting the camera but, that doesn't seem to fix anything. I've also tried resetting the alignment transform before stopping the ARSession and that doesn't seem to do anything either.

Has anyone ran into this problem before or know how to fix it? It seems like the scale, position, and rotation axis of the world changed completely. Is there a way to reset this?

Product Version: UE 4.19
Tags:
more ▼

asked Nov 20 '18 at 07:54 PM in Blueprint Scripting

avatar image

Dtb49
70 2 5 8

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

AR is implemented with the "lock to hmd" option in the camera. Disabling this option in the non-AR pawn fixed the problem for me.

more ▼

answered Jan 25 '19 at 06:28 PM

avatar image

aubertaxel
45 6 7 12

avatar image geverk Jan 28 '19 at 10:29 AM

oh great, it works for me! I have try a hundred options until I found your solution. Thanks

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question