x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

CDO Constructor: Failed to find Blueprint (UE 4.4)

Hello, i have this error after create the FirstPersonMesh in the "FirstPersonShooter Example". example from here

This error comes only if i launch the game, not in editor with play.

Error: CDO Constructor: Failed to find Blueprint'/Game/Blueprints/BP_FPSCharacter2.BP_FPSCharacter2'
But this BP exists...

The copied reference is: "Blueprint'/Game/Blueprints/BP_FPSCharacter2.BP_FPSCharacter2'"

In the AFPSGameMode constructor:

     // set default pawn class to our Blueprinted character
 static ConstructorHelpers::FObjectFinder<UBlueprint> PlayerPawnObject( TEXT( "Blueprint'/Game/Blueprints/BP_FPSCharacter2.BP_FPSCharacter2'" ) );
 if ( PlayerPawnObject.Object != NULL )
 {
     DefaultPawnClass = (UClass*) PlayerPawnObject.Object->GeneratedClass;
 }
   

Play in editor works fine, but after hit 'launch' prints this error.
The editor show this BP in the "Scene Outliner" as active actor called "BP_FPSCharacter2_C1".

I found some older answers; add "_C" to BP finder - but then is this BP not found in editor AND after launch.
Can anyone help me please?

Edit1: BTW - i make the same example with UE 4.3.1 and this works fine! Make again in 4.4 and launch failed again with same error.

Product Version: Not Selected
Tags:
more ▼

asked Aug 17 '14 at 09:32 AM in C++ Programming

avatar image

HolmHansen
31 2 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Right answer is here:

https://answers.unrealengine.com/questions/127212/bdontloadblueprintoutsideeditortrue-by-default.html

We shouldn't load UBlueprint, but directly its UClass wich is generated from actual blueprint, I suppose.

As stated MulleDK19:

For Blueprint'/Game/dice/D4_Dice_BP.D4_Dice_BP'

The class reference is Class'/Game/dice/D4_Dice_BP.D4_Dice_BP_C'

Note that menu item 'Copy Reference' non working good for that and shoud be fixed some day :)

My problem with Android packaging was solved by this approach.

more ▼

answered Sep 22 '15 at 04:05 PM

avatar image

MorskoyZmey
377 12 159 44

avatar image Acrossfy Apr 27 '17 at 01:22 AM

Thaks. This answer is really the best and the right one.

avatar image darkgaze Sep 01 '18 at 05:00 PM

Note you have to add a _C (which is the class name of the blueprint) at the end of the ref!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I ran into something similar to this where it wouldn't find blueprints when I deployed to Android. Hopefully the fix is the same for you: in your project/Config folder look for DefaultEditor.ini, change bDontLoadBlueprintOutsideEditor=true to bDontLoadBlueprintOutsideEditor=false.

more ▼

answered Aug 21 '14 at 08:38 PM

avatar image

Naremus
22 3 9 17

avatar image MorskoyZmey Sep 23 '15 at 07:03 AM

I think we shouldn't walk this way. See my answer below

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello Naremus - thank you very much, your solution fix my problem! Now works fine for me. :)

more ▼

answered Aug 22 '14 at 08:05 PM

avatar image

HolmHansen
31 2 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question