Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal engine 4.21.0 becomes unresponsive if i change the engine scalability settings to "low" or "medium"

Unreal engine 4.21.0 becomes unresponsive if i change the "effects" in engine scalability settings to "low" or "medium". alt text

Product Version: UE 4.21
capture.png (987.7 kB)
more ▼

asked Nov 21 '18 at 02:51 PM in Using UE4

avatar image

26 1 3 6

avatar image g0dSamnit Dec 22 '18 at 08:17 PM

I'm having this issue in 4.21.1 as well, and the engine has to be closed via task manager. This occurs on everything including new, blank projects. i7 6700HQ, 16 GB DDR4, Geforce 1070. Will go through logs eventually.

Edit: The issue appears to have went away. I suspect it may have occurred from strange/buggy Nvidia driver behavior, as I've occasionally seen the engine force a shader recompile when changing basic scalability settings. (I've also had some builds crash with Direct3D device errors which I need to test further but also suspect that's a driver/OS related issue .) As of now, I can no longer reproduce the issue.

Edit: Happens on Surface Pro gen 1 as well, so probably has nothing to do with any vendor-specific drivers. Will sit and wait as suggested below.

avatar image Zaggoth Feb 14 '19 at 03:15 AM

If you're still having this issue, it's likely due to Effects quality changing - the engine will likely stall for a period of time and then have to recompile shaders.

Once you've compiled said shaders, this issue shouldn't happen (or at least not hang for nearly as long.)

avatar image kmssn Jun 16 '19 at 01:51 PM

got same issue with 4.22, like xNITEMAREx95 and Zaggoth answered, wait a bit and let it compile all shaders then it comes back again.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I'm also having the same issue, but I let it sit for a couple minutes and it became responsive again. However, after becoming responsive again, the engine needed to recompile ALL shaders (even on a fresh project) which took quite a bit longer than usual.

After letting the engine compile the shaders, I tried flipping through the "effects" quality settings, as well as all other quality settings, and had no issues. I went a bit further by completely quitting the engine and restarting my machine and relaunching the same blank project and had no issues with hang or crashing when adjusting any quality setting.

more ▼

answered Dec 23 '18 at 07:52 AM

avatar image

6 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question