x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Actor Teleports to Possession point

Found a weird bug and after days of debugging got nowhere so I figured I would ask for some pointers.

In my (multiplayer) game players can possess monsters (Characters controlled by AIController) and then unpossess them, returning control back to the AI controller.

Whenever client unpossesses Character and returns AI controller, that character gets teleported to location where the character was possessed. Better explained with video - https://youtu.be/9vgghZfxtvM (Ball is character1, and the green monster is character2 - AI controller just jumps every 3 seconds)

In my code (did both blueprint and c++ with same results).

  1. Client asks server to use his controller to possess specific Monster. (Server does that)

  2. During unpossess, server remembers what AI controller was character using

  3. Client asks server to possess different character, (server does that) and possesses now empty character with original AI controller during Event Unpossess

alt text

I have tried eliminating options and if I possess character for short period of time, bug does not occur. I have tried spawning a new controller instead of using the old one, same issue. The blueprint is has parent vanilla "Paper Character" class with no special movement what so ever.

Absolutely clueless so any pointer would be appreciated!

Product Version: UE 4.20
Tags:
possessionbug.png (273.9 kB)
more ▼

asked Nov 22 '18 at 12:31 AM in Blueprint Scripting

avatar image

Crispy_Penguin
44 8 12 21

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question