x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why won't my Static Mesh component in the Blueprints Component tab rotate, scale or transform?

as described there is only a scale option in the taskbar, and the scale, transform and rotate widgets in view port dont work.

Product Version: Not Selected
Tags:
more ▼

asked Aug 17 '14 at 03:44 PM in Using UE4

avatar image

bennetherwood
189 21 21 34

avatar image TinyAngryCrab Aug 17 '14 at 09:02 PM

Have you inherited from another blueprint? Inherited components cannot be changed as far as I am aware.

avatar image bennetherwood Aug 18 '14 at 10:58 AM

im not sure? ive created a non-level blueprint and have tried the pawn and actor option with no avail! but i have another blueprint which i think is based on the character blueprint and i can scale, transform and rotate the static mesh in that ?? i also noticed that i have the option to scale but it doesn't update interactively in view port but if i re-start the engine it has updated?

avatar image TinyAngryCrab Aug 18 '14 at 10:43 PM

Could you provide an image of this? It might help to work out exactly what has happened.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hey bennetherwood,

If the mesh is the Root of the Blueprint, it can't be scaled as it is the basis for all other components for that Blueprint. Try using an empty Scene Component as the Root, and make your Static Mesh the child of that. If that's not the problem, please provide a screenshot of how you have your components set up and we can look into it.

Hope that helps!

more ▼

answered Aug 18 '14 at 10:54 PM

avatar image bennetherwood Aug 19 '14 at 11:28 AM

Yes adding [ROOT] scene1 then a static mesh fixed it thanks

avatar image NickZucc Sep 24 '14 at 03:02 PM

This was really confusing when I first stated out. I wish there was some hint for me at that time. Makes sense now but I wasn't sure what was happening at the time.

avatar image Rockseller Aug 24 '15 at 05:35 PM

Heheh thanks!

(comments are locked)
10|2000 characters needed characters left

I have the same problem here. Can you please post a guide on how to add a root to the static mesh??

more ▼

answered May 06 '15 at 04:20 PM

avatar image

Sunnyseah
26 3 7 15

avatar image Ben Halliday STAFF May 06 '15 at 04:37 PM

Hi Sunnyseah,

In your Blueprint's Components tab, click the Add Component button. Scroll all the way down to the Utility section and select "Scene." After the Scene component is added, drag it up to the Root position in the hierarchy tree. This will make it the Root of the Blueprint.

You can do this most components, but using a Scene component allows you to adjust the size of the other components in the Blueprint.

Hope that helps!

avatar image Sunnyseah May 06 '15 at 04:41 PM

Oh thanks!! I found it. But the problem for me right now is that i'm trying to bring it into the widget blueprint because i have set my mesh to change it's color via selection. How can i solve this?

avatar image Ben Halliday STAFF May 06 '15 at 05:22 PM

You should probably open a new post for that question.

avatar image Sunnyseah May 06 '15 at 04:49 PM

alt text

sadas.jpg (361.5 kB)
(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question