x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unable to change inherited mesh, details panel blank.

Hi there. While trying to solve a problem I've run into a different one.

After reparenting a paper character to a Character, the resulting inherited mesh doesn't seem to be accessible. The details panel is blank and if you drag it into the Event Graph, the nodes details for Default Value - Mesh are None.

When creating a blank Character blueprint the default value for the mesh's graph node leads to this directory "SkeletalMeshComponent'/Game/Blueprints/Characters/NewBlueprint.Default__NewBlueprint_C:CharacterMesh0"

This is a blueprint only project. I've tried reparenting back and forth, reloading the editor, deleting and restoring, and doing this on another computer (My partner developer). The issue is the same when reparenting this class, which is our base class for all characters in the game.

I've included pictures of the blank details panel, where it shows "none" in the node if dragged into the event graph, and what a fresh/new character blueprint's mesh node says when dragged into the event graph (showing a path, instead of none despite no mesh being specified yet)

Thanks for any and all help.

Product Version: UE 4.21
Tags:
missingdetails.png (545.8 kB)
nonenode.png (217.7 kB)
freshblueprint.png (268.3 kB)
more ▼

asked Nov 25 '18 at 09:55 PM in Blueprint Scripting

avatar image

Tifa
15 3 4 10

avatar image Tifa Nov 29 '18 at 03:18 AM

Still having this issue, have looked into older answer hub posts. Often people aren't able to reproduce the effect and the question dies. I feel like if I could change the directory that the inherited mesh directs to I could fix it ,because in the fresh class it points to a path with seems to be the default option, rather than simply "None" instead of a path at all but with a blue print only project unless theres a way to edit the uasset file I don't know how I can fix it. Tried reparenting back and forth , playing with different things (adding, removing, recompiling) and it's still blank.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question