x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Level Streaming Brakes NavMesh on Mobile.

Anyone here Experience NavMesh Not updating or even Showing Up on mobile After Level Streaming?

I m Using Android as Platform .. and any time I Introduce BP level Streaming Nav mesh Is not Generated on Runtime same happens on map Travel, I'm testing this In Build / Cooked Game Developer Build. All is setup Correctly, NavMesh is Dynamic, Fixed tile size + I use Invokers, NavBounds and ReCast are in a Persistent level and Sub level just loads World Geometry.

Everything is Working in Editor with no problems I can also use "show navigation" and it will show Mesh In Editor, If I install my .apk in mobile then do map travel and load Sub level, "show navigation" is not showing anything, Is anyone run into this problem..? I'm on 4.21 engine version.

I tested without level Streaming and then Nav mesh is Working and Showing up. Only if I use streaming it seems to break.

Product Version: UE 4.21
Tags:
more ▼

asked Nov 26 '18 at 07:21 AM in Bug Reports

avatar image

Positivity
27 4 8 11

avatar image Positivity Nov 26 '18 at 02:35 PM

Here is Some Video From test in Editor, Clearly can See that. sometimes Mesh is Generated and sometimes It is not ... and it looks like on Mobile phone this is not happening at all .. https://streamable.com/xovsg

avatar image Jeff A ♦♦ STAFF Nov 26 '18 at 07:24 PM

Hello,

We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://epicsupport.force.com/unrealengine/s/

Thanks

avatar image Positivity Nov 27 '18 at 06:57 AM

I submitted the Bug in new bug submission.

avatar image LastKingsSaint Jan 14 '19 at 08:18 PM

I am getting this same exact thing on PC as well, so its not just limited to mobile. My streaming level randomly wont load the navigation mesh and sometimes it will.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question