x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Teleportation does not work correctly on Blueprint

alt textHi! I'm trying to do a teleportation. I made two almost identical blueprints. Both are my teleports. It should work as follows:

When the character enters a capsule collision after 1 second he will teleport to the other blueprint. But he does not want to teleport. I put a mesh right in the middle of the blueprint where Default Scene Root is also located there by default of UE4. But when the character goes teletranpostar to this blueprint, simply the character is not teleported.

If I move the mesh up the character still is not being teleported. If I move the mesh down it is teleported only that incorrectly, in the case, it appears above the mesh as if it had fallen. If I change the scale of the mesh to 0.0, that is, it will flatten, the teletransport works correctly. Removing the mesh from the blueprint it is teleported correctly. I need that mesh in my blueprint, without it it will not make any sense to the blueprint.

I can not tell if this is a bug. Well, I did tests on other maps and new projects and even on other versions of Unreal Engine, such as version 4.20 and the problem always persists. If I remove my mesh it works perfectly. Putting up a standard box of the editor it continues with the problem. No matter what type of mesh, the same result always occurs.

Could someone help me with this problem?

thank you who try to help me

Product Version: UE 4.21
Tags:
20181126-150507.png (118.9 kB)
more ▼

asked Nov 26 '18 at 02:04 PM in Using UE4

avatar image

Hawk2033
1 1 2

avatar image Weibye Nov 26 '18 at 03:10 PM

You need to show your code, or screenshots of the blueprints in question for anyone to be able to give you insightful answers.

avatar image Hawk2033 Nov 26 '18 at 03:19 PM

Yes, in a couple of hours I will edit my question and add a photo of the code, is that at the moment I am not near the computer. Thank you for remembering.

avatar image Evigmae Nov 26 '18 at 08:47 PM

I think you need to check out your collision settings are correct. You can't teleport an actor inside another actor that would collide with it.

avatar image Hawk2033 Nov 26 '18 at 10:38 PM

Hi! I appreciate your help. I had modified my character's collision and reversed this change to see if that was it. Nothing has changed. His response was very good. That's my problem, but I have no idea how to adjust. Tomorrow I will try to work on the collisions and adjust it.

avatar image Evigmae Nov 26 '18 at 11:14 PM

No, I mean, the mesh should not collide with your character if you wanna teleport right onto its location.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Note that where you have these graphs matters. If the other actor is actually the player you want to teleport, be sure to wire up the pin. Also your blueprint doesn't make sense. Why do you need to teleport to index zero of all Actors of type X, where X isn't currently selected? Consider using set actor location and check teleport instead. Note that the relative versions are easier to use if you want to say something like teleport 50 centimeters. Also make sure the appropriate actors generate overlap events.

more ▼

answered Nov 26 '18 at 10:53 PM

avatar image

AnotherZach
70 2 3 5

avatar image Evigmae Nov 26 '18 at 11:10 PM

Think you got the blueprint wrong, it's getting the "teleport Destination Location" from the location of the 1st actor of "get all actors of class "New Blueprint 2 array". and the actor being teleported there is the 3rd person character class, which refference he gets from "get player pawn". i mean, the nodes are a mess, but the logic is sound. I'm kinda getting this is actually inside the 3rd person character, so the teleport's target should be left empty (self).

avatar image Hawk2033 Nov 26 '18 at 11:50 PM

I thank the help of all you. I will put into practice the tips of friends. All the tips were great and well explained. Even I do not understand English one hundred percent.

avatar image Hawk2033 Nov 27 '18 at 11:17 AM

Hi! I tried to make some modifications in the collisions, but he simply teleports the character and ends up overlapping my mesh. I'll explain better. I have two Blueprints and one more blueprint of my character. When my character enters the Collision Capsule of "New Blueprint 1" he will teleport to the location of "New Blueprint 2". He does this normally, but if I put any mesh in "New Blueprint 2," he just does not teleport my character. I realized with the help of all of you that my problem is with the collision, because they can not overlap, causing in the failure in teleportation. Only I can not change that. Would there be a way to teleport my character right above my mesh? Every time I tried to change the code, it would autotransport to the same position, not going to the location of "New Blueprint 2".

If you have time, thank you very much if you could copy what I did and try to do it on your PC. To see what I'm missing and how I should stay. Of course, if you want to help me and have time. Put on a mesh if you are going to do the tests.

avatar image Hawk2033 Dec 10 '18 at 06:39 PM

Can anybody help me? I have not been able to resolve this issue yet.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question