x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

My animation blueprint won't show the mesh. Animations work fine, but animbp won't show the preview mesh or the mesh in the actual character bp, someone please help!

I have created an animation blueprint to work with my characters skeleton. Each individual animation works fine. However when i try to use them in the animation blueprint the preview mesh dissapears. Then when i add that skeleton to the character file and set it to use the animbp i made, the mesh also dissapears? Someone please help! been through every setting ican think of!

Product Version: UE 4.21
Tags:
more ▼

asked Nov 26 '18 at 10:05 PM in Using UE4

avatar image

rconnor410
6 1 1

avatar image jollarvia Dec 09 '18 at 09:56 PM

This is exactly my problem too. When I use the default Third person anim bp things work fine. Even replaced it with my character mesh and the mesh is visible and the animations don't play. That I expect. But when I use my custom anim bp I get no mesh. Just an empty capsule. In the pic you will see the mesh apears in the animation and physics tab thumbnail but not the blueprint thumbnail. I also don't see the character in the anim preview.alt text It would be a great help to 2 ppl if someone knows what's going on.

ue4animproblem.png (669.2 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Just wanted to update you on my status in case anyone else needs this info. Turns out the scale of my animations was different from my mesh. if you try scaling the mesh up you'll see what I mean. What ultimately did it for me was reimporting my mesh and animations with the "convert to unreal units" option off. I was exporting from Blender by the way. If you were using something different the flow is probably the same.

more ▼

answered Dec 15 '18 at 02:49 PM

avatar image

jollarvia
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question