x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

"AI Move To" Foot Slide Problem

Hi, I created a corral containing 5 pigs, a big one, four piglets, two of them chilling from time to time, and the other two got a slightly aggressive behaviour. Pathfinding, resting and attacking works fine so far. But the piggies always slide through the corral instead of using the walk/run-state of their Anim_BP. After three days of searching forums, changing values or enabling/disabling functions of the character movement, or changing animation rates, I'm pretty desperate right now.

I would really like to stick to my "simple" blueprint scripting without using behaviour trees or root motion. Everything works fine except that damn "paw" sliding. Here is a screenshot of my movement settings as well as a short video of my piggies, including the sight of my piggy-cam I use to simulate a transmigration of souls. :P

alt text

Pawslide

Product Version: UE 4.19
Tags:
pawslide.png (301.8 kB)
more ▼

asked Nov 29 '18 at 02:09 PM in Blueprint Scripting

avatar image

Morhol
6 1 2

avatar image Morhol Nov 29 '18 at 07:28 PM

Ahh...I got it! After 3 days of torturing my brain and messing with settings I finally found the mistake. I duplicated my initial pig to create my four piglets, but I didn't create an individual Anim_BP for them. So they all were using the main pig's Anim_BP, that referred to that pigs mesh. No wonder that they only slided over the ground. Now the Chillpig has its own Anim_BP as well as the Aggropig and they act fine.

Last problem is that my Blendspace doesn't work as intended. The pigs are always running regardless where I alter MaxWalkSpeed, I created a workaroud with a seperate "Running"-state, that triggers when Speed is over 300. Works so far, but a working blendspace would be much nicer. Any suggestions?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question