x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Weird shadow spots after build everywhere.

Dear game developer,

While the title may be unclear to you, after looking at the screenshots, you'll totally know where I'm talking about.

https://1drv.ms/u/s!Avqi6Pt1BGP3gbcS9pxDSg0yqqfx-A

It appears after building lightning.

I have had multiple issues with shadows, but this just looks awful.

Where do these shadows come from?

I can't build a game like this.

Lightmap resolution seems unrelated to me.

I have not found any post like this, so if you can post a solution to this issue, others will see it and than we can get rid of it once and for all.

I hope to hear from you soon and thank you for your attention!

https://1drv.ms/u/s!Avqi6Pt1BGP3gbcQt_95CC4S_pEV2w https://1drv.ms/u/s!Avqi6Pt1BGP3gbcPxENlfO-PbTrkgg https://1drv.ms/u/s!Avqi6Pt1BGP3gbcOjz98ylaOvH2_hg https://1drv.ms/u/s!Avqi6Pt1BGP3gbcT7_TTKIl3Jmh9fQ https://1drv.ms/u/s!Avqi6Pt1BGP3gbcU0gpceSo9oDpmMw https://1drv.ms/u/s!Avqi6Pt1BGP3gbcVnByj8jjGQaZhSA https://1drv.ms/u/s!Avqi6Pt1BGP3gbcWsPMFHuC38QUwEA https://1drv.ms/u/s!Avqi6Pt1BGP3gbcXHfej7QmdbLmIdw https://1drv.ms/u/s!Avqi6Pt1BGP3gbcYa-T3qQA4jeIS6A https://1drv.ms/u/s!Avqi6Pt1BGP3gbcZKBFAJX7BCdzhNA https://1drv.ms/u/s!Avqi6Pt1BGP3gbcaCwQY8IpJmVHjSg https://1drv.ms/u/s!Avqi6Pt1BGP3gbcdLZw2_eAtyclBOw https://1drv.ms/u/s!Avqi6Pt1BGP3gbccxDGNAa4Wqh1g3w https://1drv.ms/u/s!Avqi6Pt1BGP3gbcbfH9ZSOvdjHpRsw

Product Version: UE 4.21
Tags:
more ▼

asked Jan 28 '19 at 02:02 PM in Rendering

avatar image

kevincrans
6 2 4

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Dear MakiGirl,

I fixed our issue making all lights stationary, so now my character finally has a shadow and the spots are gone. still I don't believe it was my lighting resolution, cause that was just scaling those shadow projectiles, while the source of the problem continues to persist.

I still don't know how to solve our issue, but that's fine, because I stepped over on using Unreal Engine 3 (UDK) for my project now.

I will still continue to read this post to be up to date to the newest solutions.

However you were talking about Z fighting, which is not relevant at all.

So thank you all for your attention and support, I hope to hear from you soon.

Sincerely,

Kevin Crans

more ▼

answered Mar 13 '19 at 08:06 PM

avatar image

kevincrans
6 2 4

(comments are locked)
10|2000 characters needed characters left

Hi!

I've just checked out the first few screenshots... Well those pixelated shadows do come from low resolution lightmaps! The size of those rectangular shaped shadows are the exact size of a unit you set to your object and give Unreal to work with! ...also you have z fighting too: your scene is not built up properly for Unreal...

more ▼

answered Dec 03 '18 at 03:16 PM

avatar image

Makigirl
1.1k 3 4 8

avatar image kevincrans Dec 04 '18 at 11:52 AM

Dear Makigirl,

Thank you for your reply! You are right, how higher I set the lightmap resolution, how further the shadows fade away.

But these shadow shapes still stay present.

I already know you I can fix the pixelation and bulkiness of shadows highering the lightmap resolution.

But t's not about the shadows not being straight enough.

It's about the presence and inaccuracy of these shadows.

You see, these shadows don't look anything like the walls and doors.

When I cut and paste all light actors, all shadows change from location, meaning they are not based on logic.

Well, guess I'll stick temporary to a higher lightmap resolution for now.

I hope this issue can be fixed in the future and thank you for your attention!

Sincerely,

Kevin Crans

(comments are locked)
10|2000 characters needed characters left

My issue still hasn't been fixed at April 14, 2019

more ▼

answered Jan 28 '19 at 11:13 AM

avatar image

kevincrans
6 2 4

avatar image Makigirl Jan 28 '19 at 04:49 PM

I'd still say it's YOUR settings that causing it and it's NOT a bug! ;)

avatar image kevincrans Mar 13 '19 at 08:13 PM

But it is my issue and it still hasn't got a permanent fix if those spots are caused by Z fighting, I could easily build my map over again if someone could just tell me how to do it right apart from hiding the problem. It could be another setting of me that's wrong or entirely my way of adding and substracting, please tell me.

avatar image Makigirl Mar 14 '19 at 04:45 PM

I don't understand what permanent fix you're waiting for... Unreal doesn't have a bug or something: IT'S YOUR SETTING that causing the problem!!!

Z fighting means that you have overlapping faces and once one of the faces is visible and another time the other... to solve that you'll need to build objects without duplicated polygons...

I don't know anything about your settings so I can't tell you what is your problem! But I'm guessing that you're having most of your meshes together (as 1 mesh) and not separated and you adjust a small (or even high) lightmap to it! If there is not enough lightmap resolution to visualize the proper lighting information all you'll have is blurry, low res inaccurate lighting build! If you adjust a 4x4 pixel texture to a whole apartment floor all you'll get is a blurry "nothing" right? Well the same thing is happening with lightmaps too! I can also imagine that you have the default lightmass setting even with compressed lightmaps on which won't give a clean result... ... ...

avatar image kevincrans Apr 13 '19 at 04:47 PM

Sorry for the late response, but I'm mainly working with UE1 and UDK now. I don't even use a lot of meshes, I'm mainly using brush and my issue, not unreal's is the black shadow spots, not the resolution of it nor meshes. I'm still not using a lot yet. At least one thing I do not have is overlapping brushes. So now Z-fighting clearly isn't my issue, what is? One thing what's not wrong is something to do with scalability. There's something wrong entirely, I mean do you even see this projectile?https://am3pap001files.storage.live.com/y4plNdj2NmnPpa0QvEfTGcMzhYFBaWs0Tqe_7RTQfZlkA96kqsE8Gx1T17uCZFK_23S0Hz0c6Rk9A0ggQty5ptRJiJdIb-VEp-x6-dClBznbwHn4CBj2YyTMpa2gaiRWfE3RY49S7rxjfcFIZem0nAv1g_45m_PgTcF3TFnidxdCjqK8N0VKaMj0LQfx_mYA2h_/2018-12-01%20%2814%29.png?psid=1&width=1918&height=1063 I don't know what you were thinking, but that is not supposed to be there. However, MY issue continues to persist a little longer, it looks like.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question