Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to change shadow quality.

So in my game. I have a three buttons that will toggle the different setting of shadow quality. The buttons are in a user interface widget. I want the last button to be the low quality shadow (no shadows) and the first button to be the max quality shadows. Is there any way to do this and if so, can anyone send an example blueprint. Thanks in advance.

Product Version: UE 4.20
more ▼

asked Dec 04 '18 at 02:13 AM in Blueprint Scripting

avatar image

115 2 3 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

You can use the Set Shadow Quality node, where you can select value from 0 to 4 (0:low, 1:medium, 2:high, 3:epic, 4:cinematic), or you can use the Execute Console Command node with command "r.ShadowQuality=#", where # takes the same value from 0 to 4.

more ▼

answered Dec 04 '18 at 07:42 AM

avatar image

1.8k 12 7 8

avatar image CODE REDBALLG Dec 04 '18 at 03:57 PM

Hello Tuerer. I have done what you have said blinded the shadow qualities to five buttons. They all work except when I press the last button (0 Shadow Quality) The shadows won’t turn off. How would I fix this error and completely disable the shadows at 0.

avatar image Tuerer Dec 04 '18 at 04:27 PM

Idk if there's a console command or some overall settings for that, but you can always try and Set Cast Shadows to false for all your light components.

avatar image CODE REDBALLG Dec 04 '18 at 08:10 PM

I have seen YouTube videos of people setting their shadow quality to 0, and all the lights turning off. Why isn’t that happening to me and how can I make that happen?

avatar image Aguywhocanfly Jan 31 '19 at 12:34 PM

I too would really like to know about this, except in my case none of these nodes are changing the shadows at all. I need shadows to be toggled on/off globally and this would be perfect. Any idea why they aren't working?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question