x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

First Person Character falling through the floor

Hello everyone, I'm still a novice using the UE4 and I'm facing an issue with my first person character falling through the floor. I searched alot, saw youtube tutorials and the UE4 docs, tryed all the solutions that I found but didn't solve the problem. I checked my Project Settings, with the right Default Pawn Class as FirstPersonCharacter and Default Game Mode as FirstPersonGameMode; also set the Editor Start Up Map and Game Default Map to the right level; I have my Input Bindings set correctly (Action and Axis Mappings); I set the floor collision I set the Can character Step Up On to Yes and the Collision Presets tryed both as Default and also BlockAll ; I have the Player Start and on the Blueprints everything seems fine. The problem persists, maybe its a simple issue to solve but I don't find a solution, does anyone have a clue of what the problem might be? I'll attach a video of the falling. Best regards everyone! alt text

Product Version: UE 4.21
Tags:
more ▼

asked Dec 04 '18 at 06:24 PM in Using UE4

avatar image

Nanaminaga
1 1 3

avatar image NoCodeBugsFree Dec 04 '18 at 06:41 PM

1) make a collision on the floor mesh 2) put blocking volume according your floor location 3) check your pawn capsule component collision (it must block all) and collision must be enabled

avatar image Nanaminaga Dec 04 '18 at 07:31 PM

Thank you very much for the reply! The 1) I already had a collision on the floor, but didn't had the Blocking Volume, also on the 3) I had BlockAll but not sure if the collision is enabled? I'll attach the screenshoots so you can check if I used the Blocking Volume right and the options are ok. If everythings is right still doens't work :(

alt text

alt text

alt text

alt text

1.png (1.1 MB)
2.png (1.3 MB)
3.png (1.3 MB)
4.png (58.5 kB)
avatar image NoCodeBugsFree Dec 05 '18 at 06:20 AM

"I already had a collision on the floor, but didn't had the Blocking Volume" - one of them is enough. Look at your last image. Open hidden menu by clicking little triangle before collision presets. I think you need to setup collision presets (in both actors - in pawn and in floor) accordingly to desired behavior. (e.g. your floor's object type is World Static and collision presets are BlockAll, and Pawn Capsule's object type is Pawn, and collision presets Are Pawn. So this way will force this two object block each other). Please, spend some time to watch this link text

I think it will be very helpful.

avatar image Nanaminaga Dec 05 '18 at 01:21 PM

Thank you very much for the reply. I already had those presets, I think they are right, will attach the images so you can check, I tried alot of different preset that I saw on youtube tutorials and I've already read all the documents about collision, I think I didn't miss anything, but maybe I did but can't figure what it is. The problem still presist.

alt text alt text

01.png (51.5 kB)
02.png (49.3 kB)
avatar image NoCodeBugsFree Dec 05 '18 at 01:34 PM

if your floor mesh itself has a collision (collision->add box simple collision) and properly setup - my knowledge is depleted. I'm very sorry.alt text

1.jpg (213.1 kB)
avatar image Nanaminaga Dec 05 '18 at 03:03 PM

Yes, it has a Box simple collision, I also tried a complex one. Yours seems really fit to the box and mine is a little bit up could it be that? But it should be automatic I think. I'm really glad for your help. I'll keep trying to solve this, but its so strange since everything seems to be right. If I find a solution I'll post here, until then I hope someone else can help! Thank you very much :D

![alt text][1]

03.png (1.4 MB)
avatar image NoCodeBugsFree Dec 05 '18 at 06:13 PM

just for test, try your floor it in new project. I have no idea what is going on.

avatar image Nanaminaga Dec 05 '18 at 08:36 PM

I did it, and the floor worked in the other project, so it should work on this project but its not and they have the same settings, its really strange. :/

avatar image Nanaminaga Dec 09 '18 at 04:40 PM

Hello guys! I didn't find a solution to this problem, I think its probably a bug, because I recreated the project, but this time after I imported Datasmith, I did the collision for the floor and put the first person character and worked fine without the falling, with the same settings I had on the previous project, so I think it can be a bug since all the settings were the same but I did the collisions and character after everything else. Doing the collision and setting up the character as a first step in the project (before everything else, like build lights, blueprints, materials, etc) prevented the issue.

Thank you for all the help everyone! Best regards.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I am experiencing this exact same issue with imported CAD model via datasmith into a pre-built level with all actors set up correctly as a starter template. I will kee investigating and post if I find a solution. I’m a newbie also so maybe something simple but I have also applied collisions.

Regards Andre

more ▼

answered Dec 14 '18 at 05:04 PM

avatar image

eCoMake Architecture
1 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question