x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can not load map, failed to load assets

Hello and good day,

I have a huge problem and I hope anyone can help me with this urgent issue, I would really appreciate it. It would save me weeks of work.

The problem is as follows, today we had a power outage in my apartment building. I was thinking to my self, luckily there is an autosave function with this engine or else I have big problems. But as it turns out, when I loaded up my project when the electricity came back on there was an error in my project.

Everything loads fine, except for the level I was working on. It does not load, nothing happens when I left click with my mouse. But if I right click with my mouse, there is an error message that states: Failed to load assets. I click to see the error message, but there is nothing! This is really frustrating because I worked over a week on this level. Thou I have saved several times and the engine also autosaves.

Any help would be greatly appreciated.

Product Version: UE 4.19
Tags:
more ▼

asked Dec 07 '18 at 01:47 PM in Using UE4

avatar image

Sophic
17 1 3

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Try this:
- Duplicate the project (as to not lose any important changes).
- In the new project, delete "Intermediate" and "Saved" folders.
- Open new project and see if the map can be opened.

more ▼

answered Dec 07 '18 at 02:33 PM

avatar image

Weibye
215 1 6 5

avatar image Sophic Dec 07 '18 at 02:45 PM

Thank you for your help, I will try this and let you know of the progress.

avatar image Sophic Dec 07 '18 at 03:25 PM

Unfortunately, when I open the project I get a message stating: Failed to open map file. This is most likely because the map was saved with a newer version of the engine.

Then I try to open the level, but the same happened as before.

avatar image Weibye Dec 07 '18 at 03:31 PM

the map was saved with a newer version of the engine.

Is there any reason why you can't simply migrate the entire project to the new engine version that the map was created in?

Unreal doesn't like the combination of new assets with old engines, so if you create a blueprint or map in version 4.20 and try using those in 4.18, you won't be able to open them.

Solution is to only create assets within the engine version you have decided on using, and only ever upgrade engine versions.

avatar image Sophic Dec 08 '18 at 06:39 AM

Thank you for your suggestion @Weibye The problem is that the map was made in the same engine version. That is why it is so strange. I even migrated the map to a clean project in the same engine version. Still the same issue, and no error logs! This is crazy, but I could re-make the whole level from memory. But I waste so much time, and the error still stands.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question