x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't package for Adroid because of ImmediatePhysics.uplugin

I can't package my project for android since I've switched to 4.21. I've got such error: ERROR: System.IO.DirectoryNotFoundException: Nie można odnaleźć części ścieżki „N:\UE4_Engines_Epic_Engines\UE_4.21\Engine\Plugins\Runtime\ImmediatePhysics\ImmediatePhysics.uplugin”. Which in translation means that Part of path to given file can't be found. Project is building for win x64 just fine. I don't use any plugins in this project. Other project builds fine. Any ideas?

Product Version: UE 4.21
Tags:
more ▼

asked Dec 15 '18 at 07:51 PM in Packaging & Deployment

avatar image

Gomo
126 4 10 12

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

You using plugins as some of them are turned on by default. But your case is quite interesting, the plugin it complains about by look of it in 4.21 been absorbed to engine source code, in to engine module. That means somewhere in configuration you have left over from older version of the engine, do the project you worked with been run on older version?

You can try solve it by brute force by adding this entry in to uproject file:

 "Plugins": [
     {
         "Name": "ImmediatePhysics",
         "Enabled": false
     }
       ]

In case if you already have Plugins entry you just add thing in {} and add comma at then end of last {} entry, uproject is JSON formated so i hope you know how to format it properly ;p

You can try deleting Saved directory in your project directory, but some things may reset from that. Are more radical way delete Saved directory in engine directory.

more ▼

answered Dec 15 '18 at 11:18 PM

avatar image

Shadowriver
33.9k 916 164 1093

avatar image Gomo Dec 16 '18 at 02:49 AM

Yes, project was started many versions ago. I've tried deleting saved folder and config files, but I'll try to disable like you proposed in project file, I hope it will help. Thanks!

avatar image Gomo Dec 16 '18 at 03:03 AM

Unfortunately it didn't' helped. I'm attaching Log file (I don't understand why it is partially translated - I thing it should be disabled by default) link text

projectlauncher.log (171.2 kB)
(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question