x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Lightning disappearing?

Hi! I'm using one of the Paragon gadget mesh particle effect to create a lightning effect. The problem is that it disappears at certain camera angle. Almost as if the mesh is being culled. How do i prevent that? Video below:

https://youtu.be/ILtRvb4Hi8c

Product Version: UE 4.21
Tags:
more ▼

asked Dec 17 '18 at 05:56 AM in Rendering

avatar image

mihovil
3 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It does look like its been culled, probably because of the bound of the mesh being too small for its actual size (most probably because the mesh has no collisions at all). To check if thats the case you can, in Editor, go to the top of the viewport, click on show->advanced->bounds. This way you will be able to see if thats the issue. Whenever the bound of the mesh its out of sight, it will get culled, irregardless of the actual size of the mesh.

To fix it you have to go into your mesh properties, and then increase the possitive and negative bound extensions (in general settings of the mesh, you need to expand the section).

Hope that helps! Have a nice day!

more ▼

answered Dec 17 '18 at 11:13 AM

avatar image

Bariudol
944 21 13 29

avatar image mihovil Dec 17 '18 at 04:15 PM

Thanks. I had to go to particle effect, tick use fixed relative bounding box, and change Max X value from 1 to 100. Then i was able to see that bound is covering the whole mesh.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question