x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Only first 127 morph targets affect appearance of my model

I've cloned UE4 from official GitHub page https://github.com/EpicGames/UnrealEngine and compiled it successfully on my Xubuntu 18.04.

I have a FBX file exported from DAZ Studio 4.10. The model contains about 230 morph targets. I've imported the file into UE4 and got the following warnings (don't think it's related, but still)

 Warning skeletal mesh influence count of 13 exceeds max count of 8. Influence truncation will occur. Maximum Ignored Weight 0.029 
 No smoothing group information was found in this FBX scene.  Please make sure to enable the 'Export Smoothing Groups' option in the FBX Exporter plug-in before exporting the file.  Even for tools that don't support smoothing groups, the FBX Exporter will generate appropriate smoothing data at export-time so that correct vertex normals can be inferred while importing. 

I open Mesh View -> Morph Target Preview and change weights of the morph targets. They affect my mesh visually, but when it comes to 128th morph target, I cannot see the difference between 0 weight and 5 — looks like they don't work, but any morphs from the first to 127th worked fine. Nevertheless, I can change any coefficient using FBX SDK in an application written by me, so the morphs really exist and should affect appearance of the mesh.

How to fix the issue?

Product Version: UE 4.20
Tags:
more ▼

asked Dec 17 '18 at 04:29 PM in Using UE4

avatar image

valeriy-krygin
1 1

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Workaround is to go to Edit > Project Settings > Rendering > Optimizations and turn off Use GPU for computing morph targets. You can find this instruction in MorphTargetPreviewer documentation.

Also, it's said that the bug should be fixed in Unreal Engine 4.21 (4.21.2-release works for me).

more ▼

answered Feb 01 '19 at 02:00 PM

avatar image

valeriy-krygin
1 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question