x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to get audio rendered alongside video using sequencer?

So I understand that in Unreal version 4.21, the users are presented the option to render audio in a separate .wav file in addition to the .avi file of the video using the command line arguement -audiomixer. However, the documentation for this is really sparse and not many have actually been able to do it. So any guidance in the right direction would be much appreciated. I'll walk everyone down the process I'm following:-

1) Opened the project and enabled the Audio capture, Sound utilities and Synthesizer plugin. Restarted the editor.

2) Next, enabled the "Allow background Audio" and disabled "Enable Editor Sounds" in Editor Preferences under Level Editor - Miscellaneous.

3) Also, disabled "Use less CPU when in background" in General - Performance of Editor Preferences.

4) Navigate to the project directory and open the .uproject file with the -audiomixer arguement

5) I have the Audios which I want to record along with the video inside the sequencer, like shown in the Image below

alt text

6) I set the sequencer with the following settings as advised here :-https://answers.unrealengine.com/questions/843636/build-421-preview-4-sequencer-still-not-rendering.html

alt text

I can hear the audio files playing when the rendering is taking place in the seperate window, but the end result doesn't have the audio (.wav) file. Not even an empty one. Am I missing a step or is something wrong with my configuration?

Product Version: UE 4.21
Tags:
more ▼

asked Dec 18 '18 at 12:55 PM in Rendering

avatar image

gurankas
13 1 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question