x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Game Crashes on Mobile Device when call Open Level

hey UE4 Community, Again i am stuck with a problem and I cannot solve it on my own.

My problem: When I package my Project and put it on my phone for testing (Galaxy S8+) with the Newest Android version, The StartMenu opens. When I press play and try to Open Level "MainLevel" it crashes all the time. When I do it on Editor or when I use launch on device, it works fine. But the packaged version "ETC1" just crashes when I try to open a new Level.

What I tried: I searched alot tried some things but nowthing helped.

1.Packaging everything, what's included in Content Folder.

  1. Packaging only with selected content and maps.

  2. Disabled unused plugins.

  3. Packaged in different versions like (Multi,ATC, ETC1, ETC1a...)

  4. toggled compressed cook packages

  5. Tried different Min. and Target SDK versions

  6. I ve also uploaded the App on Google play Console and installed it from google play. Same result.

  7. Tried using different Path for open level ("MainLevel", "/Game/Levels/Mainlevel", "/Levels/MainLevel")

  8. Disabled Savegame function to test if loading variables are causing this issue..

Nothing helped yet. When I package the apk file. I just put the apk file onto the phone via usb and install the apk inside the phone. I couldn't get it installed via the batch file, because it keeps telling me, that the device could not be found.

I am programming the most in c++ and all UI related things in blueprint.

I hope someone can help me with this issue.

Product Version: UE 4.21
Tags:
more ▼

asked Dec 18 '18 at 05:08 PM in Packaging & Deployment

avatar image

AnGaraa
10 4 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi, is it possible you are using any non-mobile friendly assets (high poly or high resolution textures) that crashes the phones gpu? or maybe using any features that arnt meant for mobile, like the ui background blur.

Hope this helps katuta

more ▼

answered Dec 18 '18 at 05:28 PM

avatar image

Katuta
26 1 2 4

avatar image AnGaraa Dec 18 '18 at 05:41 PM

I dont think so. Every texture was made by myself 256x256 or 512x512. Also the objects are made in blender by myself. I tried to keep everything as simple as possible. And I can play the game when launching to Device through the editor. There are no problems

avatar image Katuta Dec 18 '18 at 09:23 PM

have you tried to build on another mobile device to see if its your apk or the phone?

avatar image AnGaraa Dec 18 '18 at 09:32 PM

yes on a galaxy s6. its the same result

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question