x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AI not moving on a moving surface. Sometimes.

I have a moving walkable surface [static mesh], and there is AI characters ontop of it that are told to walk from one path node to another ontop of this surface. I press play and it works fine they can walk from one point to another and don't stop through the playthrough.

But after stopping the simulation I press play again and this time, for what seems like no reason at all the characters never move from one point to another. Sometimes they rotate a little bit and move towards their path node a little bit but stop at the same time.

Sometimes the character that is closer to the player(and the center of the world moves towards its path node and stops very quickly while the other is unresponsive and I have clicked the play and escape button like 100 times now.

Ok now I've noticed that even the AI character on the static surface doesn't move sometimes.

These are my settings for runtime nav meshs. alt text

This is a picture of the set up I have. alt text The grey surface is the static surface. alt text

And this is a picture of the movable surface code I have. alt text

Product Version: UE 4.21
Tags:
more ▼

asked Dec 23 '18 at 10:54 PM in Bug Reports

avatar image

mindsurferdev
3 1

avatar image Jeff A ♦♦ STAFF Dec 26 '18 at 04:08 PM

Hello,

We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://epicsupport.force.com/unrealengine/s/

Thanks

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question